Skip to content

Commit

Permalink
dev-util/idea-community: add 2023.1.5
Browse files Browse the repository at this point in the history
Signed-off-by: Mike Pagano <[email protected]>
  • Loading branch information
mpagano committed Jul 26, 2023
1 parent f518b5b commit c2bceb4
Show file tree
Hide file tree
Showing 2 changed files with 130 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/idea-community/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST idea-community-2023.1.4.tar.gz 938207113 BLAKE2B 9a5e2bd6cdde79be971c098c5f0bcd235ede08690619f3a027b39b74a496fcdac1acb1c141b8dc970bd8552ecb10e869c23502b7508d0576bcf67c7adb06a0b4 SHA512 3d99d767eb255a5eb92f23736dabfc9efb91c7894bbe9e377bdba838ce80351e95084374c4a9a17b3e1afecfb0c5017c7cedf8f8ddae7dad20d38c441a88e6a2
DIST idea-community-2023.1.5.tar.gz 938204327 BLAKE2B 66949f0d4f0aff274e4eac28acbc5d31da46a25af0f0b41ee2c930afe35cd339dcef7b3e9ac3f34a0785e99cd4c4f61fa8f63e2c4da17b20b0499ca6922bcb27 SHA512 de48e5268573f031c703191a338a17287f8f81e92475535c2f631bdb41257d53ccd4d9c9bc11cea441e4c7fe0263b7db96c0955fcacf33f7c52b21346ba218a9
129 changes: 129 additions & 0 deletions dev-util/idea-community/idea-community-2023.1.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,129 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
inherit desktop wrapper

DESCRIPTION="A complete toolset for web, mobile and enterprise development"
HOMEPAGE="https://www.jetbrains.com/idea"
SRC_URI="https://download.jetbrains.com/idea/ideaIC-${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 CC-BY-2.5 CDDL-1.1
codehaus-classworlds CPL-1.0 EPL-1.0 EPL-2.0
GPL-2 GPL-2-with-classpath-exception ISC
JDOM LGPL-2.1 LGPL-2.1+ LGPL-3-with-linking-exception MIT
MPL-1.0 MPL-1.1 OFL ZLIB"

SLOT="0"
KEYWORDS="~amd64 ~arm64"

DEPEND="
|| (
>=dev-java/openjdk-17.0.6_p10:17
>=dev-java/openjdk-bin-17.0.6_p10:17
)"

RDEPEND="${DEPEND}
sys-libs/glibc
media-libs/harfbuzz
dev-java/jansi-native
dev-libs/libdbusmenu"

BDEPEND="dev-util/patchelf"
RESTRICT="splitdebug"
S="${WORKDIR}/idea-IC-${PV}"

QA_PREBUILT="opt/${PN}/*"

src_unpack() {

default_src_unpack
if [ ! -d "$S" ]; then
einfo "Renaming source directory to predictable name..."
mv $(ls "${WORKDIR}") "idea-IC-${PV}" || die
fi
}

src_prepare() {

default_src_prepare

if use amd64; then
JRE_DIR=jre64
else
JRE_DIR=jre
fi

PLUGIN_DIR="${S}/${JRE_DIR}/lib/"

# rm LLDBFrontEnd after licensing questions with Gentoo License Team
rm -vf "${S}"/plugins/Kotlin/bin/linux/LLDBFrontend
rm -vf ${PLUGIN_DIR}/libavplugin*
rm -vf "${S}"/plugins/maven/lib/maven3/lib/jansi-native/*/libjansi*
rm -vrf "${S}"/lib/pty4j-native/linux/ppc64le
rm -vf "${S}"/bin/libdbm64*
rm -vf "${S}"/lib/pty4j-native/linux/mips64el/libpty.so
rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-aarch64/libquiche.so

if [[ -d "${S}"/"${JRE_DIR}" ]]; then
for file in "${PLUGIN_DIR}"/{libfxplugins.so,libjfxmedia.so}
do
if [[ -f "$file" ]]; then
patchelf --set-rpath '$ORIGIN' $file || die
fi
done
fi

rm -vf "${S}"/lib/pty4j-native/linux/x86-64/libpty.so

sed -i \
-e "\$a\\\\" \
-e "\$a#-----------------------------------------------------------------------" \
-e "\$a# Disable automatic updates as these are handled through Gentoo's" \
-e "\$a# package manager. See bug #704494" \
-e "\$a#-----------------------------------------------------------------------" \
-e "\$aide.no.platform.update=Gentoo" bin/idea.properties

eapply_user
}

src_install() {
local dir="/opt/${PN}"
local dst="${D}${dir}"

insinto "${dir}"
doins -r *
fperms 755 "${dir}"/bin/{format.sh,idea.sh,inspect.sh,restart.py,fsnotifier}
if use amd64; then
JRE_DIR=jre64
else
JRE_DIR=jre
fi

JRE_BINARIES="jaotc java javapackager jjs jrunscript keytool pack200 rmid rmiregistry unpack200"
if [[ -d ${JRE_DIR} ]]; then
for jrebin in $JRE_BINARIES; do
fperms 755 "${dir}"/"${JRE_DIR}"/bin/"${jrebin}"
done
fi

# bundled script is always lowercase, and doesn't have -ultimate, -professional suffix.
local bundled_script_name="${PN%-*}.sh"
make_wrapper "${PN}" "${dir}/bin/$bundled_script_name" || die

local pngfile="$(find ${dst}/bin -maxdepth 1 -iname '*.png')"
newicon $pngfile "${PN}.png" || die "we died"

make_desktop_entry "${PN}" "IntelliJ Idea Community Edition" "${PN}" "Development;IDE;"

# recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
mkdir -p "${D}/etc/sysctl.d/" || die
echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die

# remove bundled harfbuzz
rm -f "${D}"/lib/libharfbuzz.so || die "Unable to remove bundled harfbuzz"

# remove bundled java
rm -r ${dst}/jbr || die "Unable to remove bundled java"

}

0 comments on commit c2bceb4

Please sign in to comment.