forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ruby/gettext_i18n_rails: add 1.3.1
Package-Manager: portage-2.2.20.1
- Loading branch information
Showing
2 changed files
with
38 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST gettext_i18n_rails-1.2.2.tar.gz 20254 SHA256 4bdaff360864211ee8739155f881cbe505d36ae8ec0d592c8180779f6f84a35e SHA512 c2a02a2aaa118581e81b3ff375ebfb8b4e58fc2313e8d7f321d881370b546d906eec51f848d27f2996ca16938bc7580ed6c27d780d1531a251578ce9260bcb40 WHIRLPOOL c674993506104a8475b7a2be422f11558aa001f362cdc7786fc27cf3b44368ce5855a0ecdc555e28345ad81cd14c70d785c5952cd8bbf6506a0720534c658d38 | ||
DIST gettext_i18n_rails-1.2.3.tar.gz 20252 SHA256 48af9946c8165ece5c1c94c01045596e25f00bc679e3eb835e45992663444fd7 SHA512 b28bea0100ca5dd307ead1b77f4e71b491eb12899d772394c6e3ea73150ef4277c7305de0dfd2429ccc635af462f0b0f4f42280cdb666ebc7cee2cf9a43a04a2 WHIRLPOOL f54222b9940b58e16a2e1e27eb36d044ae42fe4b9ed1e06edeb57f5ea1e1ebc727de1cd564cd3679f0851b47fc5ebe93d3913a2ef90de8ebd56917a08ba19913 | ||
DIST gettext_i18n_rails-1.3.0.tar.gz 20218 SHA256 b52a90e45d6bcdfac828cebbf52892ccadb320d148bb14a8267f8545b4347877 SHA512 90136a441aad8c5b26fe39454b675b444ff5cdfa87c4d6ec1738583ea5b6db793b1d05db94e9084905249a75f19239acf5812e6e8350d3ee2537aed76387c2d2 WHIRLPOOL b8503ad978faeeaff0a966be62392bbc0ef4361f28575e50afb799431fb311368b656a4c702749d4dd12f2e342f4c79abe5fe1cd56f64aa41441c073e53449e6 | ||
DIST gettext_i18n_rails-1.3.1.tar.gz 20261 SHA256 d50193878e7b8eee61ba48fe33c10f7eed28afdcb7e500dd135743cbc9ffd72f SHA512 761c941aa4d4a746067b84c703b7ca661af3229a2886113a0c5beb1872efd5e74dae7bcf0c6bb476078e636835d19a66e93c8c9c7850024c4ca025e153f1b708 WHIRLPOOL 0b865211641224a5dfc6e76e88297fc2cc8576789a099ca65bc3deefb95318313ec8bae24070fde65c0cd219402cc928265b7ef626435836d3fa8e908ad4ece4 |
37 changes: 37 additions & 0 deletions
37
dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.3.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,37 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
USE_RUBY="ruby20 ruby21" | ||
|
||
RUBY_FAKEGEM_TASK_DOC="" | ||
RUBY_FAKEGEM_EXTRADOC="Readme.md" | ||
|
||
RUBY_FAKEGEM_RECIPE_TEST="rspec3" | ||
|
||
inherit ruby-fakegem | ||
|
||
DESCRIPTION="FastGettext / Rails integration" | ||
HOMEPAGE="https://github.com/grosser/gettext_i18n_rails" | ||
SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="public-domain" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
ruby_add_bdepend "test? ( dev-ruby/rails:4.0 dev-ruby/activerecord:4.0[sqlite] dev-ruby/temple )" | ||
ruby_add_rdepend ">=dev-ruby/fast_gettext-0.9.0" | ||
|
||
all_ruby_prepare() { | ||
rm Gemfile Gemfile.lock || die | ||
|
||
# Remove specs for slim and hamlet, template engines we don't package. | ||
rm spec/gettext_i18n_rails/slim_parser_spec.rb spec/gettext_i18n_rails/haml_parser_spec.rb || die | ||
|
||
# Test against Rails 4.0 (newer versions don't work and we don't use | ||
# appraisals for now). | ||
sed -e '1igem "rails", "~>4.2.0"' -i spec/spec_helper.rb || die | ||
} |