Skip to content

Commit

Permalink
dev-python/GitPython: Bump to 3.1.43
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Apr 1, 2024
1 parent 5cc2af5 commit c2db85e
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
79 changes: 79 additions & 0 deletions dev-python/GitPython/GitPython-3.1.43.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,79 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"

inherit distutils-r1 pypi

TEST_P=GitPython-${PV}
GITDB_P=gitdb-4.0.11
SMMAP_P=smmap-5.0.1

DESCRIPTION="Library used to interact with Git repositories"
HOMEPAGE="
https://github.com/gitpython-developers/GitPython/
https://pypi.org/project/GitPython/
"
SRC_URI+="
test? (
https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
)
"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"

RDEPEND="
dev-vcs/git
>=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
>=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

src_test() {
git config --global user.email "[email protected]" || die
git config --global user.name "Travis Runner" || die

git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
"${T}"/test/git/ext/gitdb || die
git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
"${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die

cd "${T}"/test || die
git rev-parse HEAD > .git/refs/remotes/origin/master || die
TRAVIS=1 ./init-tests-after-clone.sh || die
cat test/fixtures/.gitconfig >> ~/.gitconfig || die

distutils-r1_src_test
}

python_test() {
local EPYTEST_DESELECT=(
# performance tests are unreliable by design
test/performance
# unimportant and problematic
test/test_installation.py
# Internet
test/test_quick_doc.py::QuickDoc::test_cloned_repo_object
# TODO
test/test_submodule.py::TestSubmodule::test_base_rw
test/test_submodule.py::TestSubmodule::test_root_module
)

epytest -o addopts= test
}
2 changes: 2 additions & 0 deletions dev-python/GitPython/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,6 @@
DIST GitPython-3.1.42.gitbundle 10271846 BLAKE2B 72023a523c0bf888d1fa356a303feff19e142018d7d21722510b7fff69174794feed8fdda84c6fc4c8738c551634924331e48eb82dac71d8c5ebcf145296f6bd SHA512 c7b5ce6bf4500f6350bd1b260317e235fb16d4b8d3dfce9849a845a96d466f61eba9d40f18a0c7d302718f856d08f9c50bde811cadedb78d1dd2ebddaf9cfe48
DIST GitPython-3.1.42.tar.gz 203449 BLAKE2B 7c18cb6cf0cc10b3269889bd7f4b0c3b61fd0ed765b3723c5bdf331a6e030bdc76587ce1c8e3d8ca5d7cb003968b74c6079b466a6afd3326c418f16e81ed9291 SHA512 f83d5fadc5fbd4d7837d42bc78bc07a9609bb0a10f5938de8d6c88da91de5638fafd6df23e468f7c23c19e11b4fbf273c19858336791ff199997dbe4e1aec91e
DIST GitPython-3.1.43.gitbundle 10674326 BLAKE2B c430e6fec138077502dce16a1a100459c30134af7865a2e228646791465a7176ee3ef4db5cc83081f56b5e9877aeb4ba7e54b0526d6c2f594520335db4b48e9e SHA512 8c4b2fdf2e382393420bee1cb19929171d72e72669ac3ef96ff112119d803775aae92a14908b9bd51873f102ab85dfadd940b0789da6179b0f99354ae4b6d469
DIST GitPython-3.1.43.tar.gz 214149 BLAKE2B bc95520b839a43b88571678d7dadd3998a613a4e4f5b0e59f8740add7794767db2820e2d68a98940976ed27fa57b6e487895b1f3d2894b55f1d7f4e06757a461 SHA512 c193418bbb6ebb4f202c4f6aa95b731acf319d6560db176aa7126cf848a1f11eea9f432c4ff6812e8ddb5f8386b1fa5e10335fbf170f3ec3ac5fd2dcde783415
DIST gitdb-4.0.11.gitbundle 1620355 BLAKE2B 8095193318d4262b8ebb04f35a0500eda8757057ed472dbaaece53e6afa6227e2b2c02a2be5daa5e4c0cc43dcbb5046555407d3d7c8dbed0bc5c415515032b8d SHA512 17e404b335a3c081f4058aeba5c57e5697a580f8ad7a280fde868968cf48f5a0852bfa45019eab730279582c0c536f8204e973d93af09da05908477329d73360
DIST smmap-5.0.1.gitbundle 362567 BLAKE2B 72c8b48ad3250a33b94218c145c02033dee84c1da5f1eea57983a58699262d51844be675330d95c7d64924b6aeaacd4b0a57e9a5acad3be184aaad62102202e7 SHA512 9ca8386bfec25d1562cdf1c2ee85f7edb15fd3f44ecd1abbef738979f12b82f0b0f39a06589203a39f89518d981d7129e35f64f2d855cd162cd964bdd87c8d18

0 comments on commit c2db85e

Please sign in to comment.