Skip to content

Commit

Permalink
sci-chemistry/autodock_vina: add 1.2.5
Browse files Browse the repository at this point in the history
Signed-off-by: Alexey Shvetsov <[email protected]>
  • Loading branch information
alexxy committed Mar 26, 2024
1 parent 7567e81 commit c2eae57
Show file tree
Hide file tree
Showing 3 changed files with 115 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-chemistry/autodock_vina/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST autodock_vina-1.2.5.tar.gz 24158966 BLAKE2B c11493fcb35d409b97f639c4da48967d5df450781d412d80a951b95162555f4b1dfba809a01062136a7f0664c0b9a01a42b5403ee1d278a57afd669cf1f96321 SHA512 d36908e5833d22bcbc4dae353ef32b905d6eb46511302f7583a291398bfadff5e75fc99ce7b380860578b2257e5c32434cc75b1ca51fafb4b5f12d9477a878e9
DIST autodock_vina_1_1_2.tgz 67366 BLAKE2B dc754bf522795ebfbfcf89a2df4e3761d941c1f0ce05cf56898720c1e855f5dd00fd2a583f5a8d218fa2e738d37e014a9b3239b9aa989b9018a6a33f8f0bd02c SHA512 f704af322ebc192117c49d0cf8a3f217105beccb7b47d6361665470894ef7a9f91fc4b5f07cc9aff56e497bfa80953e40e39090c8394a095c61597756e333ae9
50 changes: 50 additions & 0 deletions sci-chemistry/autodock_vina/autodock_vina-1.2.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit flag-o-matic toolchain-funcs

MY_PN=AutoDock-Vina

DESCRIPTION="Program for drug discovery, molecular docking and virtual screening"
HOMEPAGE="http://vina.scripps.edu/"
SRC_URI="https://github.com/ccsb-scripps/AutoDock-Vina/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"

S="${WORKDIR}/${MY_PN}-${PV}/build/linux/release"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"

RDEPEND="dev-libs/boost:="
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
)

src_prepare() {
cd "${WORKDIR}/${MY_PN}-${PV}" || die
pwd
sed -e "s:VERSION:\"${PV}\":g" \
-i src/main/main.cpp \
-i src/split/split.cpp || die
default
}

src_configure() {
append-cxxflags -DBOOST_FILESYSTEM_VERSION=3 -DBOOST_TIMER_ENABLE_DEPRECATED -std=c++14
}

src_compile() {
emake \
BASE="${EPREFIX}"/usr/ \
GPP="$(tc-getCXX)" \
C_OPTIONS=$(usex debug '' -DNDEBUG)
}

src_install() {
dobin vina{,_split}
}
64 changes: 64 additions & 0 deletions sci-chemistry/autodock_vina/files/autodock_vina-1.2.5-gentoo.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
diff -urN AutoDock-Vina-1.2.5.orig/build/linux/debug/Makefile AutoDock-Vina-1.2.5/build/linux/debug/Makefile
--- AutoDock-Vina-1.2.5.orig/build/linux/debug/Makefile 2024-03-05 13:23:49.210511903 +0300
+++ AutoDock-Vina-1.2.5/build/linux/debug/Makefile 2024-03-05 13:25:34.028499976 +0300
@@ -1,7 +1,7 @@
BASE=/usr
BOOST_VERSION=
BOOST_INCLUDE = $(BASE)/include
-C_PLATFORM=-static -pthread
+C_PLATFORM=-pthread
GPP=g++
C_OPTIONS= -g -std=gnu++11
BOOST_LIB_VERSION=
diff -urN AutoDock-Vina-1.2.5.orig/build/linux/release/Makefile AutoDock-Vina-1.2.5/build/linux/release/Makefile
--- AutoDock-Vina-1.2.5.orig/build/linux/release/Makefile 2024-03-05 13:23:49.213845279 +0300
+++ AutoDock-Vina-1.2.5/build/linux/release/Makefile 2024-03-05 13:26:10.285621339 +0300
@@ -1,7 +1,7 @@
BASE=/usr/local
BOOST_VERSION=
BOOST_INCLUDE = $(BASE)/include
-C_PLATFORM=-static -pthread
+C_PLATFORM=-pthread
GPP=g++
C_OPTIONS= -O3 -DNDEBUG -std=c++11
BOOST_LIB_VERSION=
diff -urN AutoDock-Vina-1.2.5.orig/build/makefile_common AutoDock-Vina-1.2.5/build/makefile_common
--- AutoDock-Vina-1.2.5.orig/build/makefile_common 2024-03-05 13:23:49.213845279 +0300
+++ AutoDock-Vina-1.2.5/build/makefile_common 2024-03-05 13:28:30.557370911 +0300
@@ -14,7 +14,7 @@
#CC = ${GPP} ${C_PLATFORM} -ansi -pedantic -Wno-long-long ${C_OPTIONS} $(INCFLAGS)
CC = ${GPP} ${C_PLATFORM} -ansi -Wno-long-long ${C_OPTIONS} $(INCFLAGS)

-LDFLAGS = -L$(BASE)/lib -L.
+LDFLAGS = -L.

# test if boost_thread-mt exists, this is
# necessary as some versions of boost only
@@ -32,22 +32,22 @@
ifeq ($(BOOST_STATIC), y)
LIBS = ${BASE}/lib/libboost_system${BOOST_LIB_VERSION}.a ${BASE}/lib/libboost_thread${threadmt}${BOOST_LIB_VERSION}.a ${BASE}/lib/libboost_serialization${BOOST_LIB_VERSION}.a ${BASE}/lib/libboost_filesystem${BOOST_LIB_VERSION}.a ${BASE}/lib/libboost_program_options${BOOST_LIB_VERSION}.a
else
-LIBS = -l boost_system${BOOST_LIB_VERSION} -l boost_thread${threadmt}${BOOST_LIB_VERSION} -l boost_serialization${BOOST_LIB_VERSION} -l boost_filesystem${BOOST_LIB_VERSION} -l boost_program_options${BOOST_LIB_VERSION}#-l pthread
+LIBS = -l boost_system -l boost_thread -l boost_serialization -l boost_filesystem -l boost_program_options -l pthread
endif

.SUFFIXES: .cpp .o

%.o : ../../../src/lib/%.cpp
- $(CC) $(CFLAGS) -o $@ -c $<
+ $(CC) $(CXXFLAGS) -o $@ -c $<

%.o : ../../../src/design/%.cpp
- $(CC) $(CFLAGS) -I ../../../src/lib -o $@ -c $<
+ $(CC) $(CXXFLAGS) -I ../../../src/lib -o $@ -c $<

%.o : ../../../src/main/%.cpp
- $(CC) $(CFLAGS) -I ../../../src/lib -o $@ -c $<
+ $(CC) $(CXXFLAGS) -I ../../../src/lib -o $@ -c $<

%.o : ../../../src/split/%.cpp
- $(CC) $(CFLAGS) -I ../../../src/lib -o $@ -c $<
+ $(CC) $(CXXFLAGS) -I ../../../src/lib -o $@ -c $<

all: vina vina_split

0 comments on commit c2eae57

Please sign in to comment.