Skip to content

Commit

Permalink
net-print/cups-filters: Bump to version 1.11.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Aug 18, 2016
1 parent d266cee commit c314ff9
Show file tree
Hide file tree
Showing 2 changed files with 123 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-print/cups-filters/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST cups-filters-1.10.0.tar.xz 1399652 SHA256 1f708a404164fb8eb341e5410e1b849b19cb47ce1bbe0d97c3673768db3401a1 SHA512 93517fe81552cac0f1414b04876db54bf94475d3ceb443c4e104e381ea5141296237576f543db0184794ade952a892a4fa6f312c4c8a4e5769827567eb181e2a WHIRLPOOL ad924de8719c807e78c6c6c7c4a561c2cee279d99a10530d4353aae0ef4e8723d4ce81dc881c7320f174ccf8e6a25491918fec4e7311d3bf49d02fbe9e623132
DIST cups-filters-1.11.1.tar.xz 1403392 SHA256 a886497313ca7f405d3b2babb85b3a4edf5702803863df4e15c9450b83ed1274 SHA512 be475126fb30690b86471733bcfd27a9696fdc0e1053e5c3ac99673608383ad446ecbc8f45ecdeced3ebe70918976f9253ea0097b54bcd01e79e9887c230c22f WHIRLPOOL 752d5cd95c27b729fab6c47af3a1286b51b624d7aa7608e83758cc392e4fb3bf09790fe6ca4d8d668ad4560df7642f114458d051e84d3e92178782d30ad24312
DIST cups-filters-1.5.0.tar.xz 1375588 SHA256 f22a8864e8d5b693795605a31345c08cc68f85120ebde9a0aa7bc27639815932 SHA512 81574f8368aaef61aeee4369caa394f2c8cdc717b03687d8a17c7927892f07cff68f1efb8d674757cb97001b55fd58fa5c14784a510ce9d31e385b1a73cd18c7 WHIRLPOOL 4201d08a2bb76d349a6b9f7220eb48dea86bb81c0cedbe8dcb8796c49ce26f67f6a7c49677b4fc7b6f865eb20e3c806746f565668e9f9e1e3935630621d032cd
DIST cups-filters-1.8.3.tar.xz 1373028 SHA256 e1e786f1fbcd3a203d87ebb4106a0ba8d579953cbe22056d12d4ee8143f5341a SHA512 5c3648670ae141038a373c4e800e81a7584759e3caf8c4e4468cb0da11c0ff521ac80678e603856c7209da6638673400305c38903cb27e3b4d792d17947e2af4 WHIRLPOOL 0c0ff9b767f35a61f4b9b2f57392d1a6afce35decf9216e77f7503b62bd67da0fa05f9ed507518599e03d27de50458823499989bf6bfd8d3a3da162292819157
122 changes: 122 additions & 0 deletions net-print/cups-filters/cups-filters-1.11.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,122 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

GENTOO_DEPEND_ON_PERL=no

inherit eutils perl-module systemd

if [[ "${PV}" == "9999" ]] ; then
inherit bzr
EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
else
SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
fi
DESCRIPTION="Cups PDF filters"
HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/pdf_as_standard_print_job_format"

LICENSE="MIT GPL-2"
SLOT="0"
IUSE="dbus +foomatic jpeg ldap perl png +postscript static-libs tiff zeroconf"

RDEPEND="
postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
>=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils,xpdf-headers(+)]
>=app-text/qpdf-3.0.2:=
dev-libs/glib:2
media-libs/fontconfig
media-libs/freetype:2
media-libs/lcms:2
>=net-print/cups-1.7.3
!<=net-print/cups-1.5.9999
sys-devel/bc
sys-libs/zlib
dbus? ( sys-apps/dbus )
foomatic? ( !net-print/foomatic-filters )
jpeg? ( virtual/jpeg:0 )
ldap? ( net-nds/openldap )
perl? ( dev-lang/perl:= )
png? ( media-libs/libpng:0= )
tiff? ( media-libs/tiff:0 )
zeroconf? ( net-dns/avahi[dbus] )
"
DEPEND="${RDEPEND}
dev-util/gdbus-codegen
"

src_configure() {
econf \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
--localstatedir="${EPREFIX}"/var \
--with-cups-rundir="${EPREFIX}"/run/cups \
$(use_enable dbus) \
$(use_enable zeroconf avahi) \
$(use_enable static-libs static) \
$(use_enable foomatic) \
$(use_enable ldap) \
$(use_enable postscript ghostscript) \
$(use_enable postscript ijs) \
--with-fontdir="fonts/conf.avail" \
--with-pdftops=pdftops \
--enable-imagefilters \
$(use_with jpeg) \
$(use_with png) \
$(use_with tiff) \
--with-rcdir=no \
--with-browseremoteprotocols=DNSSD,CUPS \
--without-php
}

src_compile() {
default

if use perl; then
pushd "${S}/scripting/perl" > /dev/null
perl-module_src_configure
perl-module_src_compile
popd > /dev/null
fi
}

src_install() {
default

if use perl; then
pushd "${S}/scripting/perl" > /dev/null
perl-module_src_install
perl_delete_localpod
popd > /dev/null
fi

if use postscript; then
# workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
dosym gstoraster /usr/libexec/cups/filter/pstoraster
dosym gstopxl /usr/libexec/cups/filter/pstopxl
fi

prune_libtool_files --all

cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die

if ! use zeroconf ; then
sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
fi

doinitd "${T}"/cups-browsed
systemd_dounit "${S}/utils/cups-browsed.service"
}

src_test() {
emake check
}

pkg_postinst() {
if ! use foomatic ; then
ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
fi
}

0 comments on commit c314ff9

Please sign in to comment.