Skip to content

Commit

Permalink
dev-python/attrs: version bump to 17.3.0
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Nov 15, 2017
1 parent 39ec2c7 commit c325a1f
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/attrs/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST attrs-16.3.0.tar.gz 57512 SHA256 80203177723e36f3bbe15aa8553da6e80d47bfe53647220ccaa9ad7a5e473ccc SHA512 1a91e6f27ecaf20c409c3abf88ffed5c6cfdbba8cff44637399b713271ff838a054f5859dd29440b2780d81b40673033e3f8e43dd491bece72e0a4f08c4ef688 WHIRLPOOL 85d53df74265b6db36171ad84c21321fd8f4b3c345ea65c46b627a25e586399c8cd7d3231417c7450ea9bb8237286434828f1c795759bdcf4d459f63555c8636
DIST attrs-17.2.0.tar.gz 73733 SHA256 5d4d1b99f94d69338f485984127e4473b3ab9e20f43821b0e546cc3b2302fd11 SHA512 02243e59ff417deddb330e841d42c0f43d3bea4435f114d3a9a8f4c3bd424c2ef565c630d179db7b3687d22091bf6e619de661171248c0ff0a0e5ec5f9bf7e21 WHIRLPOOL 422abbabec76ca9932f071c5f8ca77afecbbbc08b0cc7e199588a945afe215aa9509922a667fd1a2da7e8fd79b8abd29c366c42c4dad2d538f2487729c4450bb
DIST attrs-17.3.0.tar.gz 89046 SHA256 c78f53e32d7cf36d8597c8a2c7e3c0ad210f97b9509e152e4c37fa80869f823c SHA512 69a104a0a00c13946ca61c5e21a6acd4e75a43c775d54f270c9da3fd9475df54997c32a25a5c47a24012daac2f525457b1727fb2bb7291afb90627bf87d818ee WHIRLPOOL 4bddc25ea332001058e4f81f8d8eda8aa42fa7a5f6614c43767fbc0151f697fd97f8201e28da2ab7c9b9056420d7b1fc50f65f00f799131a2ec84a1f48cb2fe6
33 changes: 33 additions & 0 deletions dev-python/attrs/attrs-17.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )

inherit distutils-r1

DESCRIPTION="Attributes without boilerplate"
HOMEPAGE="
https://github.com/hynek/attrs
https://attrs.readthedocs.org/
https://pypi.python.org/pypi/attrs"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="test"

RDEPEND="dev-python/zope-interface[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-lang/python[sqlite]
>=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
)"

python_test() {
py.test -v || die "tests failed with ${EPYTHON}"
}

0 comments on commit c325a1f

Please sign in to comment.