Skip to content

Commit

Permalink
dev-util/clion: version bump to 2017.2.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
strahlc authored and mgorny committed Aug 5, 2017
1 parent f76214d commit c325a7d
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/clion/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST clion-143.1186.tar.gz 220702330 SHA256 a2d6960afbfae77f59481c5ad30bc7c5afe9451bdf9d12cd9435f605b57b522b SHA512 d4ea1bad5f3da3bab569380114011798c29e633009867c8020363c9af72326ebaa3232dff9c931a67dd0a0195bf4903647e250963c7aeebe9ad83340c988cbad WHIRLPOOL 2a0855b6a32a5e23a1c7266d7a3dc00ad3ba905c5a8fa6d1e9959d6d4f67c73d35c94bfbe0837fde0d1736bd48dcb9212a219cfa81732cb169abdb1fb5dc4dd7
DIST clion-2016.2.1.tar.gz 287103613 SHA256 444f760740811d0bb135cdd7d1d3a559b4d3247cdabf4eb9f77a21eea8c74805 SHA512 a4734c1b5d544cb7f6bd4752f5853d3c44e123e8ad8584b76098ef51a00261350d49bdd628d08c171f7c04b77862e8f28b5d8f16813c282542f83a16100c7415 WHIRLPOOL 83737f1677fff6870fd4dd717d54126f6680ec7c4966bc4b89f300e1fd327a431a13ceb6b04a52287c89813a7bb0e86ebaddf5c98f0330d595314c465d4a9534
DIST clion-2017.2.1.tar.gz 317210113 SHA256 acd3d09a37a3fa922a85a48635d1b230d559ea68917e2e7895caf16460d50c13 SHA512 f1f1194039cbd8495872cb7c117312dd30e39eef6d2cf58083dbc0637a803d677ef18dd353da780e9e6daf63384f9514efc3845a16f5ab3245084ca641a563f8 WHIRLPOOL b7c72989e9e91a01d136298d4037b7e45691a5cd714aef9bb0eabc4f8fe69f1a0f8ab2019de57da8d18600998523b641b2a47080829cf930ec6cd897d00c2acc
DIST clion-2017.2.tar.gz 315270710 SHA256 de7f47ec959be9653aa4d2028fb27f8327800d8370daa0ab2d1093f3469f4b49 SHA512 f7600d78cb20332b388ecca2174d69c2e2bf370d0137d4e57eb64032f598f2afb41e7e8ff47fb8db532c6a1e426b0d60194f53f4707a9faa2589b7449b598893 WHIRLPOOL 41884bb5831b403f9769894a1d2889e303e6a6d32bdf0930dfb7b0f35b7a7408fd08dae090db5cc7127570cb232fc9f9fb5db355cb541e59d31f9deaeb6694ab
61 changes: 61 additions & 0 deletions dev-util/clion/clion-2017.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils

SLOT="0"

SRC_URI="http://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
DESCRIPTION="A complete toolset for C and C++ development"
HOMEPAGE="http://www.jetbrains.com/clion"

KEYWORDS="~amd64 ~x86"
LICENSE="IDEA
|| ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"

# RDEPENDS may cause false positives in repoman.
# clion requires cmake and gdb at runtime to build and debug C/C++ projects
RDEPEND="
sys-devel/gdb
dev-util/cmake"

QA_PREBUILT="opt/${P}/*"

src_prepare() {
default

local remove_me=(
bin/gdb/bin
bin/gdb/lib
bin/gdb/share
bin/cmake
license/CMake*
plugins/tfsIntegration/lib/native/hpux
plugins/tfsIntegration/lib/native/solaris
)

use amd64 || remove_me+=( plugins/tfsIntegration/lib/native/linux/x86_64 )
use arm || remove_me+=( bin/fsnotifier-arm plugins/tfsIntegration/lib/native/linux/arm )
use ppc || remove_me+=( plugins/tfsIntegration/lib/native/linux/ppc )
use x86 || remove_me+=( plugins/tfsIntegration/lib/native/linux/x86 )

rm -rv "${remove_me[@]}" || die
}

src_install() {
local dir="/opt/${P}"

insinto "${dir}"
doins -r *
fperms 755 "${dir}"/bin/{clion.sh,fsnotifier{,64}}

make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
newicon "bin/${PN}.svg" "${PN}.svg"
make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"

# recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
mkdir -p "${D}/etc/sysctl.d/" || die
echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
}

0 comments on commit c325a7d

Please sign in to comment.