Skip to content

Commit

Permalink
sys-fs/vhba: Bump to 20211218
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Dec 19, 2021
1 parent 908aba4 commit c347227
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/vhba/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST vhba-module-20211023.tar.xz 16144 BLAKE2B 70f922c9cf4de5e495ccf812c2b4eecbf3ba4dc49bb59763b97754505198506de4fce7789a4ef6e93dce4cef5275f7aff6c5c45b856a40ad6f62a5fae58d7187 SHA512 e398f8bbdff8d57d001633d98d3720d7cd424d0279de96d9d3e30dcc9013eedc4afaef4e2ab9962306e2073b30ed9d36ccff328253e1d6d36fde1944b2b78e5a
DIST vhba-module-20211218.tar.xz 16168 BLAKE2B 37fcc56cc34dfbc68c8a8212f30a54c6a04f3b9014a5964b995bfef59df1b8f5a005e6cbfff97f1233451d215b6c4fd3c09a0cd39ebf6cb86bd6b327e5d7d718 SHA512 02b554bb2d0c91c090edeeb7c692164f378273e475a64653df845cb30cdd15d689f7fbe5fa890f77f82bf778d4d228384f656d202b6b6baf02d08321d7c2598d
50 changes: 50 additions & 0 deletions sys-fs/vhba/vhba-20211218.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit linux-mod udev

MY_P=vhba-module-${PV}
DESCRIPTION="Virtual (SCSI) Host Bus Adapter kernel module for the CDEmu suite"
HOMEPAGE="https://cdemu.sourceforge.io/"
SRC_URI="https://download.sourceforge.net/cdemu/vhba-module/${MY_P}.tar.xz"
S=${WORKDIR}/${MY_P}

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="virtual/udev"
DEPEND="${RDEPEND}
virtual/pkgconfig"

MODULE_NAMES="vhba(block:${S})"
BUILD_TARGETS=modules

pkg_setup() {
CONFIG_CHECK="~BLK_DEV_SR ~CHR_DEV_SG"
check_extra_config
BUILD_PARAMS="KDIR=${KV_OUT_DIR}"
linux-mod_pkg_setup
}

src_prepare() {
# Avoid -Werror problems
sed -i -e '/ccflags/s/-Werror/-Wall/' Makefile || die "sed failed"

eapply_user
}

src_install() {
dodoc AUTHORS ChangeLog README
linux-mod_src_install

einfo "Generating udev rules ..."
udev_newrules - 69-vhba.rules <<-EOF
# do not edit this file, it will be overwritten on update
#
KERNEL=="vhba_ctl", SUBSYSTEM=="misc", TAG+="uaccess"
EOF
}

0 comments on commit c347227

Please sign in to comment.