forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
3 changed files
with
57 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST pychroot-0.9.11.tar.gz 17904 SHA256 986a49997bb90e78e68cc99363659e01482adc0158c895d621f754b7d1a1870e SHA512 0cc169b79dd29e4c712b6764a6cf83f91d71383664276faca676a848b00b34203fc6f4430bc0c6f4a099959e76fc06f08d4f3679fceaaf8126dc1c1c78283ea7 WHIRLPOOL 9ce13e27390c46cfe43ca597e55bd786ad338b513a60864d4bb040cf84a97c1e4d9e3c044d4c7c6f2d10ed0b7b815a7b4239a3aee40486df834a722e8803c914 | ||
DIST pychroot-0.9.12.tar.gz 19791 SHA256 a536341b52d1e50ddbd20a999a24ca927d9efc1a2dc14a0488e6b2a7c9eeb7cb SHA512 27f8913fb624b928e9be07ea3e70fbc4a987d1313570f67d7c433fa96c31931defb661cb18734fb0f766bab494a0429d7931227224783fa3cd62faf44e005ee0 WHIRLPOOL 64dcc7fa3ec797d885fd96c332621fbcf42510094626a0de5e984096239ec0c7e7bb1246fb35dff503f6a7fe8ae348e3dca102a1c9bd8dd13646cb5d975b0ec0 | ||
DIST pychroot-0.9.9.tar.gz 11936 SHA256 49558bdc85dbdd25dbd2b3417eb857bd770bfb026db76c7e2bcedc8c605fe76b SHA512 437e8fa1a7d13a884c6fccb0e0cc81de8ccd6ff63ca0b3d2f55dcaa0c9cbef0c81cd033d64e08c1d35805f1d7e568fe941128c569827d7ae641d2d3b2ca4c1c2 WHIRLPOOL 40b3deb33d865efa37ce0b78a4471a531c6c6d542750ef87bb54071084a3bbdb115ffec92fef9086c3cc0ca63f9a71c65e3a4daa88f30cede7e4a5cbbd3f4851 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,51 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
PYTHON_COMPAT=( python{2_7,3_3,3_4} ) | ||
inherit distutils-r1 | ||
|
||
if [[ ${PV} == *9999 ]] ; then | ||
EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git" | ||
inherit git-r3 | ||
else | ||
KEYWORDS="~amd64 ~x86" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
fi | ||
|
||
DESCRIPTION="a python library and cli tool that simplify chroot handling" | ||
HOMEPAGE="https://github.com/pkgcore/pychroot" | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
IUSE="test" | ||
|
||
RDEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
>=dev-python/snakeoil-0.6.5[${PYTHON_USEDEP}] | ||
" | ||
DEPEND="${RDEPEND} | ||
$(python_gen_cond_dep 'dev-python/3to2[${PYTHON_USEDEP}]' python2_7) | ||
test? ( | ||
$(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) | ||
dev-python/pytest[${PYTHON_USEDEP}] | ||
)" | ||
[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]" | ||
|
||
python_compile_all() { | ||
[[ ${PV} == *9999 ]] && emake -C doc man | ||
} | ||
|
||
python_test() { | ||
esetup.py test | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all | ||
if [[ ${PV} == *9999 ]]; then | ||
emake -C doc PREFIX=/usr DESTDIR="${D}" install_man | ||
else | ||
doman man/* | ||
fi | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters