Skip to content

Commit

Permalink
gui-wm/dwl: add 0.6
Browse files Browse the repository at this point in the history
Signed-off-by: Leonardo Hernández Hernández <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
sevz17 authored and juippis committed Jul 29, 2024
1 parent c0dd787 commit c35117b
Show file tree
Hide file tree
Showing 2 changed files with 77 additions and 0 deletions.
1 change: 1 addition & 0 deletions gui-wm/dwl/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST dwl-v0.5.tar.gz 57363 BLAKE2B 6dce89cbfa1aa1946983897bed5ac16619ac237e0f7092b588847315b849392b83643839dc5386c5bd73a36e5da55a281696a6ef13dcaec8345cb4e495c5e3b7 SHA512 7bd292559b0ecafc54bf1c1ba0c3b6b0417e8bd03bb0058f492b87295c92b50932e25621cc5f804c38ad06ffadad7bb8017872fade4a04bf617b1d4f1993aae8
DIST dwl-v0.6.tar.gz 62677 BLAKE2B 01d010c7e5054c9a8ed0b2b03093e8eee8ff11555296819f2b42a54dd5f07507d9129e6eaf34521d5743bf172309472b52d9a0106b7badd545c75e922a115ef0 SHA512 5e5d7599438d4cdf632e7afaddb1d345c8131c9925e9e4d1b632ad52c4418b1db2c0ff6a2da4b5686607c79cf2598e26e8c7f4c8385be82b2c2355fa28c2e8fb
76 changes: 76 additions & 0 deletions gui-wm/dwl/dwl-0.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit savedconfig toolchain-funcs

if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://codeberg.org/dwl/dwl.git"
inherit git-r3
else
MY_PV="${PV/_rc/-rc}"
MY_P="${PN}-v${MY_PV}"
SRC_URI="https://codeberg.org/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
fi

DESCRIPTION="dwm for Wayland"
HOMEPAGE="https://codeberg.org/dwl/dwl"

LICENSE="CC0-1.0 GPL-3+ MIT"
SLOT="0"
IUSE="X"

if [[ ${PV} == 9999 ]]; then
COMMON_DEPEND="~gui-libs/wlroots-9999:=[libinput,session,X?]"
else
COMMON_DEPEND="
>=gui-libs/wlroots-0.17:=[libinput,session,X?]
<gui-libs/wlroots-0.18:="
fi

COMMON_DEPEND+="
dev-libs/libinput:=
dev-libs/wayland
x11-libs/libxkbcommon
X? (
x11-libs/libxcb:=
x11-libs/xcb-util-wm
)
"
RDEPEND="
${COMMON_DEPEND}
X? (
x11-base/xwayland
)
"
# uses <linux/input-event-codes.h>
DEPEND="
${COMMON_DEPEND}
sys-kernel/linux-headers
"
BDEPEND="
>=dev-libs/wayland-protocols-1.32
dev-util/wayland-scanner
virtual/pkgconfig
"

src_prepare() {
restore_config config.h

default
}

src_compile() {
emake PKG_CONFIG="$(tc-getPKG_CONFIG)" CC="$(tc-getCC)" \
XWAYLAND="$(usev X -DXWAYLAND)" XLIBS="$(usev X "xcb xcb-icccm")" dwl
}

src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
dodoc CHANGELOG.md README.md

save_config config.h
}

0 comments on commit c35117b

Please sign in to comment.