Skip to content

Commit

Permalink
dev-python/mypy_extensions: Modernize the ebuild
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Aug 10, 2021
1 parent 9d10958 commit c360ebd
Showing 1 changed file with 10 additions and 16 deletions.
26 changes: 10 additions & 16 deletions dev-python/mypy_extensions/mypy_extensions-0.4.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,31 +1,25 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{7..10} pypy3 )
EAPI=8

PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1

DESCRIPTION="Optional static typing for Python"
HOMEPAGE="http://www.mypy-lang.org/"
SRC_URI="https://github.com/python/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

if [[ "${PV}" =~ [9]{4,} ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/python/${PN}"
EGIT_COMMIT="master"
else
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~x64-macos"
fi
HOMEPAGE="
http://www.mypy-lang.org/
https://github.com/python/mypy_extensions/"
SRC_URI="
https://github.com/python/mypy_extensions/archive/${PV}.tar.gz
-> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"

IUSE="test"
RESTRICT="!test? ( test )"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~x64-macos"

distutils_enable_tests unittest

python_test() {
"${PYTHON}" -m unittest discover tests -v || die "tests fail with ${EPYTHON}"
eunittest tests
}

0 comments on commit c360ebd

Please sign in to comment.