Skip to content

Commit

Permalink
app-vim/gitgutter: version bump to 20180316
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Mar 25, 2018
1 parent b5767ff commit c3642e6
Show file tree
Hide file tree
Showing 3 changed files with 36 additions and 3 deletions.
1 change: 1 addition & 0 deletions app-vim/gitgutter/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gitgutter-20170222.tar.bz2 41819 BLAKE2B eb9e381c06aaf7136bcc40029cbee98f62be6eda66dcd63ef368bcaa9a6fe01476e90ebf0a99133bc341a129c603695cdf8173b6dfb710f224b8da9297c8a13b SHA512 970a956a839c2eaa05b699e8507b239d36ad623c40d3d05d9ce82320ec93ae733de2d40619898c5ff43074e2c8f95611b94879424767fac4f2b1fe2747611f4e
DIST gitgutter-20171101.tar.gz 43534 BLAKE2B cb0b935c1b2d16a50bbecc73f4f8c657a9087bef56bef36af8ff52a7ff09d39293296eaf49507015eaeac7f4faba2a26a09a49296c28237029110068cb9f6048 SHA512 24d8ad740931df17c2c67e2a2a13e3bba7c1205ba5543f5c11353e639876f4a54e69170dc0a946660ee2e3a23a110c90f4195fa9a1ddfff19163f00d88528219
DIST gitgutter-20180316.tar.gz 46344 BLAKE2B f981753a0f8d066b7cb5c16c49cfdd1a1aac1c6623b4645b8b1abd5719470ac181e09c8b736f8b8a14e6098b60cb8f97b114dc5c2a587b6d1875fcf27b4b12cf SHA512 15873b2cccc49f8aec9de312efedc615d6fa822b45ca8ce53cc6cc878fcaf3a6ab3f02eb5d082ff329528cce1b48358846b0aba3f9d3bc8aadd29aa57d3b1a30
30 changes: 30 additions & 0 deletions app-vim/gitgutter/gitgutter-20180316.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit vim-plugin

if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/airblade/vim-gitgutter.git"
inherit git-r3
else
inherit vcs-snapshot
COMMIT_HASH="37bdd03d176c5e182c7e8dbdc79c3f71d2a04898"
SRC_URI="https://github.com/airblade/vim-gitgutter/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="vim plugin: shows a git diff in the sign column and stages/reverts hunks"
HOMEPAGE="https://github.com/airblade/vim-gitgutter/"
LICENSE="MIT"
VIM_PLUGIN_HELPFILES="${PN}.txt"

RDEPEND="dev-vcs/git"

src_prepare() {
default

# remove unwanted files
rm LICENCE README* screenshot.png unplace.vim || die
rm -r test || die
}
8 changes: 5 additions & 3 deletions app-vim/gitgutter/gitgutter-99999999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,7 @@ if [[ ${PV} == 9999* ]]; then
inherit git-r3
else
inherit vcs-snapshot
COMMIT_HASH="1e60667322b7cd1bfcba98762fbba746a888d21a"
COMMIT_HASH="37bdd03d176c5e182c7e8dbdc79c3f71d2a04898"
SRC_URI="https://github.com/airblade/vim-gitgutter/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
Expand All @@ -23,6 +23,8 @@ RDEPEND="dev-vcs/git"

src_prepare() {
default
rm LICENCE README* screenshot.png || die
rm -rf test || die

# remove unwanted files
rm LICENCE README* screenshot.png unplace.vim || die
rm -r test || die
}

0 comments on commit c3642e6

Please sign in to comment.