forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/cinnamon-screensaver: New upstream version 3.2.2
Package-Manager: portage-2.3.2
- Loading branch information
Showing
2 changed files
with
91 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST cinnamon-screensaver-2.8.0.tar.gz 146275 SHA256 595c787bdc9d3a7189d603fe065475e39ac09f957de2da8423b685ade1441036 SHA512 438ce35145d29b2cee8bb2f07191e0aeb5803e21a67ddd0a4bb13e113ac12e2e1be6b8780c657a67e9c27f8cb09aaec1e261f478432aa9fdbd1f21229294df6d WHIRLPOOL 61a2af9bdfcc4be850ff4455782f00048d12ee1d1f36cd35acdc498e4054d450946a064db8b09b6c6000b897af21cfa0a3acc699eefdef437a699e454e252dcc | ||
DIST cinnamon-screensaver-3.0.1.tar.gz 147036 SHA256 de32ab1852b605835ea0ca41f248d18b32d7805d479eb6fd5877d4de92dbb784 SHA512 d9ad3f5c09d35388811387e3a7d1a8637d59390c4f797dedc4f6ff97cff631deb009d1cd1288317ca119f5db6456c05fd99c87c135595b2b1f07882892447427 WHIRLPOOL 6b4094cff650234933d82248fc671e399956bc435d1c47aa3b6869f2ba7c3eaaf9d973e05d29f1c274b269b6be62beca0ff0b3babc3804a73d62b9329be568f2 | ||
DIST cinnamon-screensaver-3.2.2.tar.gz 120816 SHA256 d8ec85d3b984f527790d68d61156adea84f84f35bc956d32923d5116d4937df2 SHA512 0ebc5da00973b6b7972e3f7a2ee671d204cadf25ae99af8a53fd176a5070598aaec9a0def86dca47538e6334c2b6d19db09bc0ac1ec226c85b439c0762a40d18 WHIRLPOOL dfd8ba669cd5732b5ff9e32fd9a1f5076da6da333d6a0822060340948b85aba34f043bd39a24797a7cef5ea0eb2f2e5acd931e3a76883da388bd5179f9df9c33 |
90 changes: 90 additions & 0 deletions
90
gnome-extra/cinnamon-screensaver/cinnamon-screensaver-3.2.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,90 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python3_4 ) | ||
|
||
inherit autotools gnome2 multilib python-single-r1 | ||
|
||
DESCRIPTION="Screensaver for Cinnamon" | ||
HOMEPAGE="http://cinnamon.linuxmint.com/" | ||
SRC_URI="https://github.com/linuxmint/cinnamon-screensaver/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
IUSE="debug doc pam systemd" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
COMMON_DEPEND=" | ||
>=dev-libs/glib-2.37.3:2[dbus] | ||
>=x11-libs/gtk+-3.1.4:3[introspection] | ||
>=gnome-extra/cinnamon-desktop-2.6.3:0=[systemd=] | ||
>=gnome-base/gsettings-desktop-schemas-0.1.7 | ||
>=gnome-base/libgnomekbd-3.6 | ||
>=dev-libs/dbus-glib-0.78 | ||
net-libs/webkit-gtk:4[introspection] | ||
sys-apps/dbus | ||
x11-libs/libxklavier | ||
x11-libs/libX11 | ||
x11-libs/libXext | ||
x11-libs/libXrandr | ||
x11-libs/libXScrnSaver | ||
x11-libs/libXxf86misc | ||
x11-libs/libXxf86vm | ||
x11-themes/adwaita-icon-theme | ||
${PYTHON_DEPS} | ||
pam? ( virtual/pam ) | ||
systemd? ( >=sys-apps/systemd-31:0= ) | ||
" | ||
# our cinnamon-1.8 ebuilds installed a cinnamon-screensaver.desktop hack | ||
RDEPEND=" | ||
!~gnome-extra/cinnamon-1.8.8.1 | ||
!systemd? ( sys-auth/consolekit ) | ||
dev-python/pygobject:3[${PYTHON_USEDEP}] | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
>=dev-util/intltool-0.35 | ||
gnome-base/gnome-common | ||
sys-devel/gettext | ||
virtual/pkgconfig | ||
x11-proto/xextproto | ||
x11-proto/randrproto | ||
x11-proto/scrnsaverproto | ||
x11-proto/xf86miscproto | ||
doc? ( | ||
app-text/xmlto | ||
app-text/docbook-xml-dtd:4.1.2 | ||
app-text/docbook-xml-dtd:4.4 ) | ||
" | ||
|
||
pkg_setup() { | ||
python_setup | ||
} | ||
|
||
src_prepare() { | ||
python_fix_shebang screensavers | ||
eautoreconf | ||
gnome2_src_prepare | ||
} | ||
|
||
src_configure() { | ||
gnome2_src_configure \ | ||
$(usex debug --enable-debug ' ') \ | ||
# Do not use --without-console-kit, it would provide no benefit: there is | ||
# no build-time or run-time check for consolekit, $PN merely listens to | ||
# consolekit's messages over dbus. | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_pkg_postinst | ||
|
||
if ! has_version x11-misc/xscreensaver; then | ||
elog "${PN} can use screensavers from x11-misc/xscreensaver" | ||
fi | ||
|
||
} |