Skip to content

Commit

Permalink
mail-filter/rspamd: remove reload from init script for 1.1.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
djc committed Jan 30, 2016
1 parent 8987d5e commit c40a1c9
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 1 deletion.
43 changes: 43 additions & 0 deletions mail-filter/rspamd/files/rspamd.init-r1
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
#!/sbin/runscript
# Copyright 2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

extra_commands="checkconfig"
extra_started_commands="reload"

RUNDIR=/var/run/rspamd
PIDFILE=$RUNDIR/rspamd.pid

depend() {
need net
}

checkconfig() {
/usr/bin/rspamadm configtest -c /etc/rspamd/rspamd.sysvinit.conf > /dev/null \
|| return 1
}

start() {
checkconfig || return 1
ebegin "Starting ${SVCNAME}"

mkdir -m0750 -p $RUNDIR
chown rspamd:rspamd $RUNDIR
chmod g+s $RUNDIR
rm -f $RUNDIR/$SVCNAME.sock

start-stop-daemon --start --quiet --pidfile $PIDFILE -u rspamd -g rspamd \
--exec /usr/bin/rspamd
eend $?
}

stop() {
if [ "${RC_CMD}" = "restart" ] ; then
checkconfig || return 1
fi

ebegin "Stopping ${SVCNAME}"
start-stop-daemon --stop --quiet --retry=TERM/30/KILL/5 --pidfile $PIDFILE \
--exec /usr/bin/rspamd
eend $?
}
2 changes: 1 addition & 1 deletion mail-filter/rspamd/rspamd-1.1.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -50,7 +50,7 @@ src_configure() {

src_install() {
cmake-utils_src_install
newinitd "${FILESDIR}/rspamd.init" rspamd
newinitd "${FILESDIR}/rspamd.init-r1" rspamd

dodir /var/lib/rspamd
dodir /var/log/rspamd
Expand Down

0 comments on commit c40a1c9

Please sign in to comment.