Skip to content

Commit

Permalink
dev-ruby/ruby_parser: add 3.11.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
graaff committed Feb 24, 2018
1 parent 8a0648f commit c42b8d9
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/ruby_parser/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST ruby_parser-3.10.1.gem 414208 BLAKE2B 22b0df7f5b7c137e6c331b13639ccd399323bcc6d439ffd8a07ac1f0b11db9abfd1d6a6a36d6c313a86a525d55742fca6050287ef88cf2829a164cb6f0b9a110 SHA512 57abb2a972020d443baa46b2866ded1bdd5a5d6d7d5649375e9bdaf0d3884dba23d152db2e50db776bccefc51e0bf1221e1eb8c3a6468bfd5b19b2e47dd16cc8
DIST ruby_parser-3.11.0.gem 463360 BLAKE2B 6001914a0835c5f21e16eff279100335855fd833b60c7508fe66378a899af44e928afe31efb78ad1189301b1e85facba2d025c6e544a95d730f579642169eb1d SHA512 62b01b3ecbed0fbcd75a7d3515d4804dd1d8544667ad667dc36cf19cc2e380d87bb58ca56342ee4428cdf7044356cdfa2585125636a9c18ec4a460eb901baa22
DIST ruby_parser-3.9.0.gem 411648 BLAKE2B ba5247a408c24c2ac36561ed9c26b4124a61565327247ee5dc3315a9f3e1f995fd6419c19ee8013efcc2b30fd752b3c8f6dd24011d35168f7e8cbcd224ddb909 SHA512 f609084d82caf4c33a40b64ee9df473375f00c59a34ec5b419f155a54a7fb9436ffb77ace406a01974c6c0d7b11b97447da0b3053c1fd87c66eb0406a0150312
35 changes: 35 additions & 0 deletions dev-ruby/ruby_parser/ruby_parser-3.11.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

USE_RUBY="ruby22 ruby23 ruby24 ruby25"

RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"

inherit ruby-fakegem

DESCRIPTION="A ruby parser written in pure ruby"
HOMEPAGE="https://github.com/seattlerb/ruby_parser"

LICENSE="MIT"
SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

ruby_add_rdepend ">=dev-ruby/sexp_processor-4.9.0:4
!<dev-ruby/ruby_parser-2.3.1-r1"

ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.9.1 )"
ruby_add_bdepend "test? ( dev-ruby/racc >=dev-ruby/minitest-4.3 >=dev-ruby/sexp_processor-4.10.1:4 )"

DEPEND+=" test? ( dev-util/unifdef )"

all_ruby_prepare() {
# Remove reference to perforce method that is not in a released
# version of hoe-seattlerb.
#sed -i -e '/perforce/d' Rakefile || die
sed -i -e '/license/d' Rakefile || die
sed -i -e '/Hoe.plugin :isolate/ s:^:#:' Rakefile || die
}

0 comments on commit c42b8d9

Please sign in to comment.