forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-text/poppler: Bump to version 0.59.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
- Loading branch information
Lars Wendler
committed
Sep 5, 2017
1 parent
77d26be
commit c42d83f
Showing
4 changed files
with
228 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST poppler-0.45.0.tar.xz 1674464 SHA256 96dd1a6024bcdaa4530a3b49687db3d5c24ddfd072ccb37c6de0e42599728798 SHA512 b703bed35da3572801834740bf61d59b6a3ee3b88bc1b3181bde3472264be4f6b89ceacb56179d7093329946abd6ba2501acfaf209d4f543352ff9fd38c47f1b WHIRLPOOL 687b1ba816dbff1b0a69cb05914dd7fb161bfd8c0fa4e26b77bb0ad26e27f7d7d94085a1022716a8d7a7563145f0acead9fccbbd332959d0216b81b27f3632e8 | ||
DIST poppler-0.57.0.tar.xz 1703300 SHA256 0ea37de71b7db78212ebc79df59f99b66409a29c2eac4d882dae9f2397fe44d8 SHA512 197a0bf51e7fd607db83144d771904e48f266ab9e1252c688f9e7700a5bdd239670cf0363e9d77137bafa9c08fb6ddb9d066cc78a74dac7dfd717662b25cac5f WHIRLPOOL fb0c15e4834f23b2956014748f92557de9996b8a2a37cf4a7ba62ca22f01866455a933bcf0412775a8d5a8f6ba1ba463f2fd63e27fa406b5fb5bf1fd25d32000 | ||
DIST poppler-0.58.0.tar.xz 1710412 SHA256 0e42e46419ae54b02d9f2b527c6475b6011d15816918b9057dfa3aae211af832 SHA512 0675846fc99578925840cbb17083463da6ea54f7de348b946ae7d4480d9d87bd4b5069392b23a8b9bbafe0aafafaf5a200134be52d0832558104cb4aa2497aee WHIRLPOOL 658f7dfbb786c2e09558f7e89ef0832db4ff32eaef08b7360fbf468236db01b44e33374424df6b64c17f018d7b10f61e151c08026652628d387958143a5a3837 | ||
DIST poppler-0.59.0.tar.xz 1712004 SHA256 a3d626b24cd14efa9864e12584b22c9c32f51c46417d7c10ca17651f297c9641 SHA512 23777922dc95feee2a4459281081b37e124a39fc25cd00c2c3fc206f5484c13eb9ac5317f674fbbcb51e384f9a53e38b4cacbf1426c68d2bae21a7cefbc48a0e WHIRLPOOL 82ec203c17e2b2544cc0ac12d0b22bb051abf776114d17e1548f47d5e38ff289dee2e9c4b27dc16e3953b6f5b5ff0e0eeecfba73561dbc396ee0db7c5a4847e2 |
31 changes: 31 additions & 0 deletions
31
app-text/poppler/files/poppler-0.59.0-qt5-dependencies.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
From 2f7ca474ec49f805257c75cefb364e08ebd9e4d1 Mon Sep 17 00:00:00 2001 | ||
From: Johannes Huber <[email protected]> | ||
Date: Tue, 5 Sep 2017 22:58:44 +0200 | ||
Subject: [PATCH] [Qt5] Drop unused dependencies | ||
|
||
--- | ||
CMakeLists.txt | 6 ++---- | ||
1 file changed, 2 insertions(+), 4 deletions(-) | ||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index a5b0a5be..787bd0d6 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -133,12 +133,10 @@ macro_optional_find_package(Qt4) | ||
find_package(Qt5Core) | ||
find_package(Qt5Gui) | ||
find_package(Qt5Xml) | ||
-find_package(Qt5Widgets) | ||
-find_package(Qt5Test) | ||
-if (Qt5Core_FOUND AND Qt5Gui_FOUND AND Qt5Xml_FOUND AND Qt5Widgets_FOUND AND Qt5Test_FOUND) | ||
+if (Qt5Core_FOUND AND Qt5Gui_FOUND AND Qt5Xml_FOUND) | ||
set(QT5_FOUND true) | ||
else () | ||
- message("-- Package Qt5Core or Qt5Gui or Qt5Xml or Qt5Widgets or Qt5Test not found") | ||
+ message("-- Package Qt5Core or Qt5Gui or Qt5Xml not found") | ||
set(QT5_FOUND false) | ||
endif() | ||
|
||
-- | ||
2.14.1 | ||
|
50 changes: 50 additions & 0 deletions
50
app-text/poppler/files/poppler-0.59.0-respect-cflags.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,50 @@ | ||
--- poppler-0.59.0/cmake/modules/PopplerMacros.cmake | ||
+++ poppler-0.59.0/cmake/modules/PopplerMacros.cmake | ||
@@ -98,45 +98,14 @@ | ||
set(CMAKE_BUILD_TYPE RelWithDebInfo) | ||
endif(NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES) | ||
|
||
-if(CMAKE_COMPILER_IS_GNUCXX) | ||
if (NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS "5.0.0") | ||
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wsuggest-override" ) | ||
endif() | ||
|
||
- # set the default compile warnings | ||
set(DEFAULT_COMPILE_WARNINGS_NO) | ||
set(DEFAULT_COMPILE_WARNINGS_YES "-Wall -Wcast-align -fno-exceptions -fno-check-new -fno-common") | ||
set(DEFAULT_COMPILE_WARNINGS_KDE "-Wno-long-long -Wundef -D_XOPEN_SOURCE=600 -D_BSD_SOURCE -Wcast-align -Wconversion -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common") | ||
|
||
- set(CMAKE_CXX_FLAGS "-Wnon-virtual-dtor -Woverloaded-virtual -D_DEFAULT_SOURCE ${CMAKE_CXX_FLAGS}") | ||
- set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g") | ||
- set(CMAKE_CXX_FLAGS_RELEASE "-O2 -DNDEBUG") | ||
- set(CMAKE_CXX_FLAGS_DEBUG "-g -O2 -fno-reorder-blocks -fno-schedule-insns -fno-inline") | ||
- set(CMAKE_CXX_FLAGS_DEBUGFULL "-g3 -fno-inline") | ||
- set(CMAKE_CXX_FLAGS_PROFILE "-g3 -fno-inline -ftest-coverage -fprofile-arcs") | ||
- set(CMAKE_C_FLAGS "-std=c99") | ||
- set(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g") | ||
- set(CMAKE_C_FLAGS_RELEASE "-O2 -DNDEBUG") | ||
- set(CMAKE_C_FLAGS_DEBUG "-g -O2 -fno-reorder-blocks -fno-schedule-insns -fno-inline") | ||
- set(CMAKE_C_FLAGS_DEBUGFULL "-g3 -fno-inline") | ||
- set(CMAKE_C_FLAGS_PROFILE "-g3 -fno-inline -ftest-coverage -fprofile-arcs") | ||
- | ||
- poppler_check_link_flag("-Wl,--as-needed" GCC_HAS_AS_NEEDED) | ||
- if(GCC_HAS_AS_NEEDED) | ||
- set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--as-needed") | ||
- set(CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--as-needed") | ||
- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--as-needed") | ||
- endif(GCC_HAS_AS_NEEDED) | ||
-endif (CMAKE_COMPILER_IS_GNUCXX) | ||
- | ||
-if(CMAKE_C_COMPILER MATCHES "icc") | ||
- set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g") | ||
- set(CMAKE_CXX_FLAGS_RELEASE "-O2 -DNDEBUG") | ||
- set(CMAKE_CXX_FLAGS_DEBUG "-O2 -g -0b0 -noalign") | ||
- set(CMAKE_CXX_FLAGS_DEBUGFULL "-g -Ob0 -noalign") | ||
- set(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g") | ||
- set(CMAKE_C_FLAGS_RELEASE "-O2 -DNDEBUG") | ||
- set(CMAKE_C_FLAGS_DEBUG "-O2 -g -Ob0 -noalign") | ||
- set(CMAKE_C_FLAGS_DEBUGFULL "-g -Ob0 -noalign") | ||
-endif(CMAKE_C_COMPILER MATCHES "icc") | ||
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Woverloaded-virtual") | ||
|
||
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99") |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,146 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit cmake-utils toolchain-funcs xdg-utils | ||
|
||
if [[ "${PV}" == "9999" ]] ; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="git://git.freedesktop.org/git/${PN}/${PN}" | ||
SLOT="0/9999" | ||
else | ||
SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris" | ||
SLOT="0/70" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION | ||
fi | ||
|
||
DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base" | ||
HOMEPAGE="https://poppler.freedesktop.org/" | ||
|
||
LICENSE="GPL-2" | ||
IUSE="cairo cjk curl cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt4 qt5 tiff +utils" | ||
|
||
# No test data provided | ||
RESTRICT="test" | ||
|
||
COMMON_DEPEND=" | ||
>=media-libs/fontconfig-2.6.0 | ||
>=media-libs/freetype-2.3.9 | ||
sys-libs/zlib | ||
cairo? ( | ||
dev-libs/glib:2 | ||
>=x11-libs/cairo-1.10.0 | ||
introspection? ( >=dev-libs/gobject-introspection-1.32.1:= ) | ||
) | ||
curl? ( net-misc/curl ) | ||
jpeg? ( virtual/jpeg:0 ) | ||
jpeg2k? ( media-libs/openjpeg:2= ) | ||
lcms? ( media-libs/lcms:2 ) | ||
nss? ( >=dev-libs/nss-3.19:0 ) | ||
png? ( media-libs/libpng:0= ) | ||
qt4? ( | ||
dev-qt/qtcore:4 | ||
dev-qt/qtgui:4 | ||
) | ||
qt5? ( | ||
dev-qt/qtcore:5 | ||
dev-qt/qtgui:5 | ||
dev-qt/qtxml:5 | ||
) | ||
tiff? ( media-libs/tiff:0 ) | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
virtual/pkgconfig | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
cjk? ( >=app-text/poppler-data-0.4.7 ) | ||
" | ||
|
||
DOCS=(AUTHORS NEWS README README-XPDF TODO) | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PN}-0.59.0-qt5-dependencies.patch" | ||
"${FILESDIR}/${PN}-0.28.1-fix-multilib-configuration.patch" | ||
"${FILESDIR}/${PN}-0.59.0-respect-cflags.patch" | ||
"${FILESDIR}/${PN}-0.33.0-openjpeg2.patch" | ||
"${FILESDIR}/${PN}-0.40-FindQt4.patch" | ||
) | ||
|
||
src_prepare() { | ||
cmake-utils_src_prepare | ||
|
||
# Clang doesn't grok this flag, the configure nicely tests that, but | ||
# cmake just uses it, so remove it if we use clang | ||
if [[ ${CC} == clang ]] ; then | ||
sed -i -e 's/-fno-check-new//' cmake/modules/PopplerMacros.cmake || die | ||
fi | ||
|
||
if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then | ||
sed '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \ | ||
-i CMakeLists.txt || die | ||
else | ||
einfo "policy(SET CMP0002 OLD) - workaround can be removed" | ||
fi | ||
|
||
if tc-is-clang && [[ ${CHOST} == *-darwin* ]] ; then | ||
# we need to up the C++ version, bug #622526 | ||
export CXX="$(tc-getCXX) -std=c++11" | ||
fi | ||
} | ||
|
||
src_configure() { | ||
xdg_environment_reset | ||
local mycmakeargs=( | ||
-DBUILD_GTK_TESTS=OFF | ||
-DBUILD_QT4_TESTS=OFF | ||
-DBUILD_QT5_TESTS=OFF | ||
-DBUILD_CPP_TESTS=OFF | ||
-DENABLE_SPLASH=ON | ||
-DENABLE_ZLIB=ON | ||
-DENABLE_ZLIB_UNCOMPRESS=OFF | ||
-DENABLE_XPDF_HEADERS=ON | ||
-DENABLE_LIBCURL="$(usex curl)" | ||
-DENABLE_CPP="$(usex cxx)" | ||
-DENABLE_UTILS="$(usex utils)" | ||
-DSPLASH_CMYK=OFF | ||
-DUSE_FIXEDPOINT=OFF | ||
-DUSE_FLOAT=OFF | ||
-DWITH_Cairo="$(usex cairo)" | ||
-DWITH_GObjectIntrospection="$(usex introspection)" | ||
-DWITH_JPEG="$(usex jpeg)" | ||
-DWITH_NSS3="$(usex nss)" | ||
-DWITH_PNG="$(usex png)" | ||
-DWITH_Qt4="$(usex qt4)" | ||
$(cmake-utils_use_find_package qt5 Qt5Core) | ||
-DWITH_TIFF="$(usex tiff)" | ||
) | ||
if use jpeg; then | ||
mycmakeargs+=(-DENABLE_DCTDECODER=libjpeg) | ||
else | ||
mycmakeargs+=(-DENABLE_DCTDECODER=none) | ||
fi | ||
if use jpeg2k; then | ||
mycmakeargs+=(-DENABLE_LIBOPENJPEG=openjpeg2) | ||
else | ||
mycmakeargs+=(-DENABLE_LIBOPENJPEG=none) | ||
fi | ||
if use lcms; then | ||
mycmakeargs+=(-DENABLE_CMS=lcms2) | ||
else | ||
mycmakeargs+=(-DENABLE_CMS=) | ||
fi | ||
|
||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
cmake-utils_src_install | ||
|
||
# live version doesn't provide html documentation | ||
if use cairo && use doc && [[ ${PV} != 9999 ]]; then | ||
# For now install gtk-doc there | ||
insinto /usr/share/gtk-doc/html/poppler | ||
doins -r "${S}"/glib/reference/html/* | ||
fi | ||
} |