Skip to content

Commit

Permalink
dev-libs/rocclr: 3.8.0 version bump
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/741130
Package-Manager: Portage-3.0.7, Repoman-3.0.1
Signed-off-by: Craig Andrews <[email protected]>
  • Loading branch information
candrews committed Sep 20, 2020
1 parent aaea620 commit c433bb1
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-libs/rocclr/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST rocclr-3.7.0.tar.gz 881814 BLAKE2B 5d7c70d52d8c06e421bdf2a02dba35ed70509c9154fbe3b8c3193969b37970d5f52d1a67eff46abe95b8af1932f2c6931b18380d046f633a3870fe95c4bfc651 SHA512 8684cc9b4f9f63ef65bcc286b74c51e3f7d334f0245b5a1fca6d3dfa0bb552fccb6b82419b538aebe1d316aa2c41a28a9a21df459b734aa44923d66d725834e1
DIST rocclr-3.8.0.tar.gz 882055 BLAKE2B 12b62d2316f3f2886f656c8fcca946735e262e850d49ef8cdb21dc984eba121d9c37250209696b2945f80be363c8244a66c3da91bc26f8c65405b27625b9538e SHA512 79bbaa628815620824fdf320451d729f630949a0e7cb35e2eca638a93f4788175759f68666a1cae6c1320458692c145a0c577739386681d2299c887420400edb
DIST rocm-opencl-runtime-3.7.0.tar.gz 1004361 BLAKE2B 7fa9481c77884dda15a3b0335449b2879fbac000f644fc56bbd8d06c5fd77d8355f159b9b7e8920f06351e388d0df41379b7e1fcff51cf81714a28f902218e42 SHA512 6ea509dde0290f13e66497eaad587099ed6a98df967adce207afc857ecd961b65801332ca74e36173719488639480cfcffc625a007345d0e48c10c8a0efdfa3f
DIST rocm-opencl-runtime-3.8.0.tar.gz 1004339 BLAKE2B 966a5bd1d4d188004b15fe4263f2c18f6dad6a07f4bc264a5afa010f6035fbf73288966cd624e6e31e1ba584ba322d93343e3482177e6480c4a57a4150546f5a SHA512 bb4e3568e32bf6acc3c4812d7db169396a01bf90d079dc420ffb7df4bd4146d39938e76e9b386548fe64276bbf938a545c898de599113f20cc73ae98268c3d6a
44 changes: 44 additions & 0 deletions dev-libs/rocclr/rocclr-3.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake

DESCRIPTION="Radeon Open Compute Common Language Runtime"
HOMEPAGE="https://github.com/ROCm-Developer-Tools/ROCclr"
SRC_URI="https://github.com/ROCm-Developer-Tools/ROCclr/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz
https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/archive/rocm-${PV}.tar.gz -> rocm-opencl-runtime-${PV}.tar.gz"

LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~amd64"

RDEPEND=">=dev-libs/rocm-comgr-${PV}
>=dev-libs/rocr-runtime-${PV}"
DEPEND="${RDEPEND}
>=dev-libs/rocm-comgr-${PV}
virtual/opengl
>=dev-util/rocm-cmake-${PV}"

PATCHES=(
"${FILESDIR}/rocclr-3.7.0-cmake-install-destination.patch"
)

S="${WORKDIR}/ROCclr-rocm-${PV}"

src_configure() {
local mycmakeargs=(
-DUSE_COMGR_LIBRARY=YES
-DOPENCL_DIR="${WORKDIR}/ROCm-OpenCL-Runtime-rocm-${PV}"
-DCMAKE_INSTALL_PREFIX="/usr"
)
cmake_src_configure
}

src_install() {
cmake_src_install

# This should be fixed in the CMakeLists.txt
sed -e "s:${BUILD_DIR}:${EPREFIX}/usr:" -i "${D}/usr/lib/cmake/rocclr/ROCclrConfig.cmake" || die
}

0 comments on commit c433bb1

Please sign in to comment.