Skip to content

Commit

Permalink
www-client/chromium: fix build with cups disabled
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/640642
Package-Manager: Portage-2.3.19_p1, Repoman-2.3.6_p35
  • Loading branch information
floppym committed Dec 16, 2017
1 parent 1da481f commit c442878
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-client/chromium/chromium-64.0.3282.24.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -146,6 +146,7 @@ PATCHES=(
"${FILESDIR}/chromium-FORTIFY_SOURCE-r2.patch"
"${FILESDIR}/chromium-webrtc-r0.patch"
"${FILESDIR}/chromium-memcpy-r0.patch"
"${FILESDIR}/chromium-cups-r0.patch"
)

pre_build_checks() {
Expand Down
45 changes: 45 additions & 0 deletions www-client/chromium/files/chromium-cups-r0.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
From 3cf91d8d674a496d533aa106723a632b68ab26ba Mon Sep 17 00:00:00 2001
From: Tom Anderson <[email protected]>
Date: Tue, 12 Dec 2017 23:31:56 +0000
Subject: [PATCH] Fix use_cups=false build

BUG=793801
[email protected]

Change-Id: I60ee6ec48d2686d0b42ca25311a9b76009ce9768
Reviewed-on: https://chromium-review.googlesource.com/823245
Reviewed-by: Lei Zhang <[email protected]>
Commit-Queue: Thomas Anderson <[email protected]>
Cr-Commit-Position: refs/heads/master@{#523602}
---
chrome/service/cloud_print/print_system.cc | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

diff --git a/chrome/service/cloud_print/print_system.cc b/chrome/service/cloud_print/print_system.cc
index ac94c804f9..4ceba96919 100644
--- a/chrome/service/cloud_print/print_system.cc
+++ b/chrome/service/cloud_print/print_system.cc
@@ -5,6 +5,7 @@
#include "chrome/service/cloud_print/print_system.h"

#include "base/guid.h"
+#include "build/build_config.h"

namespace cloud_print {

@@ -35,5 +36,11 @@ std::string PrintSystem::GenerateProxyId() {
return base::GenerateGUID();
}

-} // namespace cloud_print
+#if defined(OS_LINUX) && !defined(USE_CUPS)
+scoped_refptr<PrintSystem> PrintSystem::CreateInstance(
+ const base::DictionaryValue*) {
+ return nullptr;
+}
+#endif

+} // namespace cloud_print
--
2.15.1

0 comments on commit c442878

Please sign in to comment.