Skip to content

Commit

Permalink
app-containers/devcontainer: bump to 0.54.1
Browse files Browse the repository at this point in the history
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed Nov 30, 2023
1 parent e27148f commit c45e235
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-containers/devcontainer/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST devcontainer-0.52.1.tgz 614268 BLAKE2B e1e2979e7d105e0082db4019260b7015c6bab9899f43e75ff1246f879bd659557404ca2f10ffa021bd5cf2caaff6f0dad53ca8b8c48e7f082d00961c9982faf0 SHA512 b182b57071c356374121dc63301f0eebaf3ea9fd0000424f31b78c47d6536d4cd74013647bcf2f50e67a0c3f528eca9e1397acf12a565fa8d5ea0688b73245c8
DIST devcontainer-0.53.0.tgz 614575 BLAKE2B b7279b629cae49da39eca9defa17055b94c95db8ed79f78ec869f15a361ae12b4142817433e789c0d1231a753a1c7cc0247d5de738981f0f17c61de82aa7a8c9 SHA512 942e3b4b4ab19de876f22fcad16a1b41e5edc271cafcbc3281f198a80156e44ea94217cfcb4e0ef63ca96e6e854e030f4f70a51e7bcc655f0cb8cf23dcf003dc
DIST devcontainer-0.54.0.tgz 603716 BLAKE2B fc3853f69b88c8d31b5bce463e9ca4e393e6084286f9f3ffc504c1bff27f90e276168ac09f42354dc1498c98ac8336ee4b85dd5605d10c7f31d156ea2f33a95b SHA512 197bfe938d31280a27c02091ac9a5288b70993e305290444fcb11886f03c81899391ca7797e532469764e54fcc3dfc93ba73f306a3f4a08d5e8b6bf38609f456
DIST devcontainer-0.54.1.tgz 603740 BLAKE2B ea3dddfa4788efa704d73fae109b7c844d64c01a3be50a94be847a037af2a8878caca546a3b99bf0e54faabca27309f75c11b480a7b7d51c8b6f3438a55f3e65 SHA512 0eb8da1b74f23c30da8ff01244760cfb0dab857a8397b4995bb8228393624e376c9a7631aa1fe87164464221b8592c6397aa687032d4f8c1fd9e6225a8b394f6
46 changes: 46 additions & 0 deletions app-containers/devcontainer/devcontainer-0.54.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DESCRIPTION="Reference implementation of the Development Containers specification"
HOMEPAGE="https://containers.dev/
https://github.com/devcontainers/cli/"
SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
-> ${P}.tgz"
S="${WORKDIR}/package"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="
net-libs/nodejs
"
BDEPEND="
>=net-libs/nodejs-16[npm]
"

DOCS=( CHANGELOG.md README.md )

src_compile() {
# Skip, nothing to compile here.
:
}

src_install() {
local -a my_npm_opts=(
--audit false
--color false
--foreground-scripts
--global
--offline
--omit dev
--prefix "${ED}/usr"
--progress false
--verbose
)
npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"

einstalldocs
}

0 comments on commit c45e235

Please sign in to comment.