Skip to content

Commit

Permalink
dev-cpp/cpp-taskflow: Version bump to 3.2.0
Browse files Browse the repository at this point in the history
Signed-off-by: Jakov Smolić <[email protected]>
  • Loading branch information
jsmolic committed Oct 1, 2021
1 parent 77af0d6 commit c46e3ba
Show file tree
Hide file tree
Showing 2 changed files with 31 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/cpp-taskflow/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cpp-taskflow-3.0.0.tar.gz 79242171 BLAKE2B 18a89fbc2dc8d37ed03a3b1002b7803c37cfa9b6f3bd6a29e53756165971ec557e2ba60b72417f400f0b1c5fe12a0d8b88ada109abc539838b7d5eb1c10f6237 SHA512 5c838ff4436ade1f3755eb6859f724188be2bfcd11baf172413a0bdc18bc516b7b911e6d83a140c95548f844a8c8b908992bdec10b3b6569876a3e3b2d5b821e
DIST cpp-taskflow-3.2.0.tar.gz 79152157 BLAKE2B 03b4b1cf772c9dec4557a706c7872de95312d4e72ec7dcef1accfd1d5eaf470e60440d75ea0c993ab494ef460dc44639719ea1732fa92c54d64dde31b90b9224 SHA512 e30d95b69f64524c9b06cf7442236998f91b1083818f06439888d78d5a1b988bc952c02fd0ec88114283cbe6c31a7bbfe810a7114998f4b5f60c4cff921bb0fa
30 changes: 30 additions & 0 deletions dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake

DESCRIPTION="Modern C++ Parallel Task Programming"
HOMEPAGE="https://cpp-taskflow.github.io"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/taskflow-${PV}"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples test"
RESTRICT="!test? ( test )"

HTML_DOCS=( docs/. )

src_configure() {
# TODO: enable CUDA via USE flag
local mycmakeargs=(
-DTF_BUILD_CUDA=OFF
-DTF_BUILD_EXAMPLES=$(usex examples)
-DTF_BUILD_TESTS=$(usex test)
)

cmake_src_configure
}

0 comments on commit c46e3ba

Please sign in to comment.