Skip to content

Commit

Permalink
dev-ruby/activerecord: add rails 5.0.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
graaff committed Jul 2, 2017
1 parent d3b1a9c commit c49ab92
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/activerecord/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,4 +4,5 @@ DIST rails-5.0.0.1.tgz 6139334 SHA256 3cbbe71d80c2813dde0d2bfa61aea57c8e6a1a3b2a
DIST rails-5.0.1.tgz 6026895 SHA256 7ee54f0175a7738e7c169fa8dc2e4ee30ba8407768804aaa56a6889525315f4e SHA512 d5c25b284b24399f81a5a8aec9c4b581d2caeff6d1f73b71dab2a50b8f55b4a86c1d723f0bae9b40bdb3d949e3d5eb65b7522bf9ca316676cafdd2cf648abb33 WHIRLPOOL 142190cc4f8edafdc39cdbab2586127815e145f4d4fa5a89f3c9b2377e70bc29f6d410359c0498fe1c83c8f811b64884ae0d7e06b20d8ffb5ec44c6b66cde49b
DIST rails-5.0.2.tgz 6034813 SHA256 4ca4ab89c06776f959edde03833f83be05002db5a1028e9276d45db6a2358cd4 SHA512 bb82bd33e47b875f3a9bc6d833492b89fbf86afff27049f1f8710a406452dee1cb5b287b0e19d6b2f45ee59181b28425916746d1b6ef835029944aff4bcf255b WHIRLPOOL 1e4bda983d10aace2b49df133b76f8fdd9246ce071b09dd00a6aa72c2f2a4fb758214427520170ca6f819ac602199087bf993debd6275e5b23184b5e7f46bff7
DIST rails-5.0.3.tgz 6041420 SHA256 0c16f63af96529c1e3d2b4476031bd024ae403322fe78e80e188a422412dc582 SHA512 5a25747507d2a8e1d2a19ce14c77a80c4f9bd5751fb343c3f405b8d9ec170d11fb866ebfedf6b850b6750399015631ab1551e6f78e097c6514061462a05e88f3 WHIRLPOOL 25fd8473a4eed2f007b99e22cb7ccf834780d4f21478a0818c44bea525f4c839610bab2b52ae5087a881f8d5519b78616f4e53e6a21f7d6f9270c0ddf648a2a5
DIST rails-5.0.4.tgz 6041948 SHA256 50f64f8c1d083d22a652ce4d594b38674a502b89ed7b913ebb9f1dce6984a32e SHA512 9a99d506606f2901f8b4afcfa8cc92e7d122b0879c619a539aee52df5b8926e6dca98e0eb14234f810b8a73730c3c051985e13ab0bab5f52cd8c11a0b112c44d WHIRLPOOL 842f3dfd691c7904804be128e4acf555076b96e5dbb8d874918a6492991f67c31faf8d4a5410969eadcef1166035f64c1fed6e8ae4f9f2b808600ea729a15808
DIST rails-5.1.1.tgz 6124695 SHA256 a09bfa7d2917865778af70dff8bd57fe01820eca0228cff85de581ee17e9adf2 SHA512 fd62506eac440f1ad9b37f20c7c712733440bc2ee676390c02e3bd50b912fe0fd53e8092c23664d47818ee62583568c6e20d2bfd5eff6d22a005289bb3bb258f WHIRLPOOL a23d6644126e6e01481c48c7089208a535188b5b32ad67cb69db36ac2044ee35bd95d4012076d7f12666aed2cbe984c75c3555889923710f10b1b91c150ccc73
80 changes: 80 additions & 0 deletions dev-ruby/activerecord/activerecord-5.0.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
USE_RUBY="ruby22 ruby23 ruby24"

# this is not null so that the dependencies will actually be filled
RUBY_FAKEGEM_TASK_TEST="test"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem versionator

DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
HOMEPAGE="https://github.com/rails/rails/"
SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~amd64-linux"
IUSE="mysql postgres sqlite"

RUBY_S="rails-${PV}/${PN}"

ruby_add_rdepend "~dev-ruby/activesupport-${PV}
~dev-ruby/activemodel-${PV}
dev-ruby/arel:7.0
sqlite? ( >=dev-ruby/sqlite3-1.3.6 )
mysql? ( || ( dev-ruby/mysql2:0.4 >=dev-ruby/mysql2-0.3.18:0.3 ) )
postgres? ( >=dev-ruby/pg-0.18.0 )"

ruby_add_bdepend "
test? (
dev-ruby/bundler
~dev-ruby/actionpack-${PV}
~dev-ruby/actionmailer-${PV}
>=dev-ruby/sqlite3-1.3.6
dev-ruby/mocha:0.14
dev-ruby/minitest:5
)"

DEPEND+=" test? ( >=dev-db/sqlite-3.12.1 )"

all_ruby_prepare() {
# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
sed -i -e '1igem "activemodel", "~>5.0.0"' test/cases/helper.rb || die
rm ../Gemfile.lock || die
sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|execjs\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
-e '/:job/,/end/ s:^:#:' \
-e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die

# Add back json in the Gemfile because we dropped some dependencies
# earlier that implicitly required it.
sed -i -e '$agem "json"' ../Gemfile || die

# Avoid test depending on mysql adapter which we don't support for
# this Rails version to simplify our dependencies.
rm test/cases/connection_specification/resolver_test.rb || die

# Avoid single test using mysql dependencies.
rm test/cases/invalid_connection_test.rb || die

# Avoid failing test that makes bad assumptions on database state.
sed -i -e '/test_do_not_call_callbacks_for_delete_all/,/^ end/ s:^:#:' \
test/cases/associations/has_many_associations_test.rb
}

each_ruby_test() {
if use sqlite; then
${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
fi
}

0 comments on commit c49ab92

Please sign in to comment.