Skip to content

Commit

Permalink
media-libs/vulkan-layers: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Nick Sarnie <[email protected]>
  • Loading branch information
sarnex committed Nov 29, 2021
1 parent 4a76a5a commit c4aa7ef
Show file tree
Hide file tree
Showing 3 changed files with 63 additions and 5 deletions.
1 change: 1 addition & 0 deletions media-libs/vulkan-layers/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST vulkan-layers-1.2.182.tar.gz 2791196 BLAKE2B e4c2a80708b7805425eb58bc360db8aa8ac9a671ef88a261f09887f59cbacb56e1375a868589864c30a9a812c91a7dc2c7d3ebc0eda5afc7cb99dfb7f70af2de SHA512 2c7541d18926507fb7f36193a5901e2d3f864749e5c9e456c32bc8e64bae58e661d01f8871c596a2b05e2e5bf86a4c80c6207d7cc942a51cafab81f052d91805
DIST vulkan-layers-1.2.189.tar.gz 2869378 BLAKE2B 54a610c95487873c470ea304f8bbf0160a9def6a06118baced0a1b14a847cc116f3a2377cf0a287b866dffe9ff9657133ba1fa7109e0c23380412ca4f389c6f1 SHA512 7fd688365cbe69d763bb233d7be2498bb5aa286ba26c4ca9d4bdeddc28cf3f69992a89d6276d3f943d198146dcc01eca36b1d8de5747ae0893244bdb15665855
DIST vulkan-layers-1.2.198.tar.gz 3555293 BLAKE2B 1a419b1b4b50241f6f4225a8666b8f6f4fc00e30dba045deeca709f4b9ff777f8a66691ef094b72cbf059c9dafee9f1ad2986108e48c8ef3974ac805c103644e SHA512 c5ac3e458987f3aa8ca21a79aa7819fbc1ca6013b6e445a82407ac0664884b90b8f79a2593368f6264a509674aa1f9584614c7c464c88d74284601f0c7636ef0
57 changes: 57 additions & 0 deletions media-libs/vulkan-layers/vulkan-layers-1.2.198.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

MY_PN=Vulkan-ValidationLayers
CMAKE_ECLASS="cmake"
PYTHON_COMPAT=( python3_{8,9} )
inherit cmake-multilib python-any-r1

if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
EGIT_SUBMODULES=()
inherit git-r3
else
SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/sdk-${PV}.0.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
S="${WORKDIR}"/${MY_PN}-sdk-${PV}.0
fi

DESCRIPTION="Vulkan Validation Layers"
HOMEPAGE="https://github.com/KhronosGroup/Vulkan-ValidationLayers"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="wayland X"

BDEPEND=">=dev-util/cmake-3.10.2"
RDEPEND="~dev-util/spirv-tools-${PV}:=[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
dev-cpp/robin-hood-hashing
~dev-util/glslang-${PV}:=[${MULTILIB_USEDEP}]
~dev-util/vulkan-headers-${PV}
wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
X? (
x11-libs/libX11:=[${MULTILIB_USEDEP}]
x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
)
"

multilib_src_configure() {
local mycmakeargs=(
-DCMAKE_C_FLAGS="${CFLAGS} -DNDEBUG"
-DCMAKE_CXX_FLAGS="${CXXFLAGS} -DNDEBUG"
-DCMAKE_SKIP_RPATH=ON
-DBUILD_LAYER_SUPPORT_FILES=ON
-DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
-DBUILD_WSI_XCB_SUPPORT=$(usex X)
-DBUILD_WSI_XLIB_SUPPORT=$(usex X)
-DBUILD_TESTS=OFF
-DGLSLANG_INSTALL_DIR="${ESYSROOT}/usr"
-DCMAKE_INSTALL_INCLUDEDIR="${EPREFIX}/usr/include/vulkan/"
-DSPIRV_HEADERS_INSTALL_DIR="${ESYSROOT}/usr/include/spirv"
)
cmake_src_configure
}
10 changes: 5 additions & 5 deletions media-libs/vulkan-layers/vulkan-layers-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -13,9 +13,9 @@ if [[ ${PV} == *9999* ]]; then
EGIT_SUBMODULES=()
inherit git-r3
else
SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/sdk-${PV}.0.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
S="${WORKDIR}"/${MY_PN}-sdk-${PV}
S="${WORKDIR}"/${MY_PN}-sdk-${PV}.0
fi

DESCRIPTION="Vulkan Validation Layers"
Expand All @@ -26,12 +26,12 @@ SLOT="0"
IUSE="wayland X"

BDEPEND=">=dev-util/cmake-3.10.2"
RDEPEND=">=dev-util/spirv-tools-20210825:=[${MULTILIB_USEDEP}]"
RDEPEND="~dev-util/spirv-tools-99999999:=[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
dev-cpp/robin-hood-hashing
>=dev-util/glslang-11.6.0:=[${MULTILIB_USEDEP}]
>=dev-util/vulkan-headers-${PV}
~dev-util/glslang-${PV}:=[${MULTILIB_USEDEP}]
~dev-util/vulkan-headers-${PV}
wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
X? (
x11-libs/libX11:=[${MULTILIB_USEDEP}]
Expand Down

0 comments on commit c4aa7ef

Please sign in to comment.