Skip to content

Commit

Permalink
dev-ruby/ruby-vte3: Depend on correct vte slot, fixing bug 595894
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
graaff committed Oct 3, 2016
1 parent 495e7e7 commit c4dd1cb
Show file tree
Hide file tree
Showing 2 changed files with 84 additions and 0 deletions.
42 changes: 42 additions & 0 deletions dev-ruby/ruby-vte3/ruby-vte3-3.0.7-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby20 ruby21 ruby22"

inherit virtualx ruby-ng-gnome2

DESCRIPTION="Ruby VTE bindings"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

DEPEND+=" x11-libs/vte:2.91"
RDEPEND+=" x11-libs/vte:2.91"

ruby_add_bdepend ">=dev-ruby/ruby-glib2-${PV}"
ruby_add_rdepend ">=dev-ruby/ruby-gtk3-${PV}"

all_ruby_prepare() {
sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die

# Avoid tests that require a real pty.
rm -f test/test-pty.rb || die
}

each_ruby_configure() {
:
}

each_ruby_compile() {
:
}

each_ruby_test() {
VIRTUALX_COMMAND="${RUBY} test/run-test.rb"
virtualmake || die
}

each_ruby_install() {
each_fakegem_install
}
42 changes: 42 additions & 0 deletions dev-ruby/ruby-vte3/ruby-vte3-3.0.8-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby21 ruby22 ruby23"

inherit virtualx ruby-ng-gnome2

DESCRIPTION="Ruby VTE bindings"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

DEPEND+=" x11-libs/vte:2.91"
RDEPEND+=" x11-libs/vte:2.91"

ruby_add_bdepend ">=dev-ruby/ruby-glib2-${PV}"
ruby_add_rdepend ">=dev-ruby/ruby-gtk3-${PV}"

all_ruby_prepare() {
sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die

# Avoid tests that require a real pty.
rm -f test/test-pty.rb || die
}

each_ruby_configure() {
:
}

each_ruby_compile() {
:
}

each_ruby_test() {
VIRTUALX_COMMAND=${RUBY}
virtualmake test/run-test.rb || die
}

each_ruby_install() {
each_fakegem_install
}

0 comments on commit c4dd1cb

Please sign in to comment.