Skip to content

Commit

Permalink
dev-java/tomcat-native: version bump
Browse files Browse the repository at this point in the history
Signed-off-by: Miroslav Šulc <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
  • Loading branch information
fordfrog committed Oct 23, 2018
1 parent be91b06 commit c500e7f
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/tomcat-native/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST tomcat-native-1.2.16-src.tar.gz 405109 BLAKE2B e153caeb82c4ac4d2a8c7c24373204edf6e691068e70c858618caf72faaee1f4d10c4529ba758e24422e8580e8b3e95d28cc942998568106ec60b8de7c196c51 SHA512 0345f85fbab406f25c25c8fc06bf55f3d166fa14bfcf542bddb5dc5db4c8c7bd0c5b71603d85261d71152ead3023b112144f2ffa5ede14ae8595013f79c802aa
DIST tomcat-native-1.2.17-src.tar.gz 408967 BLAKE2B 482b0416be01bcbe9ba55555715de37c6071502ed57f179115c3d351684621487b90e05dd488b1c2137e4813a785c1fe229241f191468bc88f7f0dd3a31562c0 SHA512 8fa946855fd14525ec0abe7b09975bbd34d6127352e90730a8afb77e16cd91715417e812a40017fee65939a9ce95faf39a9193222f441cda0ad2eb7f690e77b9
DIST tomcat-native-1.2.18-src.tar.gz 411789 BLAKE2B 16f1ecff3abfa6bf1f88c44af4a6ba58addac69bec1c257325c429fe6eec6a522fd2ae7932d68afa9bb442b0cf248731ce3e1a9db2b383f502093bf0ea5bfd23 SHA512 66481c1f36dc7ea909bf8d55075a232bf6dea3300b56d36415b13da4aefbee16cb52456f3d44b4a2b09b43cd8c7df628145a0623b9cdfa322bc2432e6c44827f
61 changes: 61 additions & 0 deletions dev-java/tomcat-native/tomcat-native-1.2.18.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit java-pkg-2 java-ant-2

DESCRIPTION="Allows Tomcat to use certain native resources for better performance"
HOMEPAGE="https://tomcat.apache.org/"
SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"

KEYWORDS="~amd64 ~x86"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="static-libs test"

RDEPEND="dev-libs/apr:1=
dev-libs/openssl:0=
>=virtual/jre-1.8"

DEPEND=">=virtual/jdk-1.8
test? ( dev-java/ant-junit:0 )"

S=${WORKDIR}/${P}-src

JAVA_ANT_REWRITE_CLASSPATH="yes"

src_configure() {
local myeconfargs=(
--with-apr="${EPREFIX}"/usr/bin/apr-1-config
--with-ssl="${EPREFIX}"/usr
)

cd native || die
econf "${myeconfargs[@]}"
}

src_compile() {
eant jar

cd native || die
default
}

src_install() {
java-pkg_newjar "dist/${P}.jar" "${PN}.jar"

cd native || die
default

! use static-libs && find "${D}" -name '*.la' -delete || die
}

src_test() {
java-pkg-2_src_test
}

pkg_postinst() {
elog "For more information, please visit"
elog "https://tomcat.apache.org/tomcat-9.0-doc/apr.html"
}

0 comments on commit c500e7f

Please sign in to comment.