forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-office/libreoffice: fix build w/ USE=clang & clang <16
Closes: https://bugs.gentoo.org/890324 Signed-off-by: Sam James <[email protected]>
- Loading branch information
1 parent
15ef3be
commit c530f30
Showing
2 changed files
with
37 additions
and
0 deletions.
There are no files selected for viewing
36 changes: 36 additions & 0 deletions
36
app-office/libreoffice/files/libreoffice-7.4.4.2-zxing-cpp-1.4.0-c++17.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,36 @@ | ||
https://gerrit.libreoffice.org/c/core/+/145479 | ||
|
||
From a7a6b436f1a83321ccba5b6b44a275205aa729e0 Mon Sep 17 00:00:00 2001 | ||
From: Sam James <[email protected]> | ||
Date: Fri, 13 Jan 2023 15:09:59 +0000 | ||
Subject: [PATCH] configure.ac: Fix build with --with-system-zxing and < Clang | ||
16 | ||
|
||
Clang 15 and older default to -std=c++14, not -std=c++17 (unlike Clang 16 onwards). | ||
|
||
This doesn't show up with GCC because GCC 11 onwards defaults to -std=c++17. | ||
|
||
The new version of libzxing requires C++ 17, per its release notes. Adapt | ||
the configure check accordingly to pass -std=c++17 when checking for its | ||
headers and save accordingly if successful. | ||
|
||
(Do this via ${CXXFLAGS_CXX11} which has the appropriate switch | ||
for our compiler, despite its name.) | ||
|
||
Bug: https://bugs.gentoo.org/890324 | ||
Change-Id: Iaaa8fdc05eea0e26416b605bfda8f2d831f8729c | ||
Signed-off-by: Sam James <[email protected]> | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -11187,7 +11187,7 @@ else | ||
continue | ||
fi | ||
dnl TODO: White space in $i would cause problems: | ||
- CXXFLAGS="$save_CXXFLAGS -I$i/ZXing" | ||
+ CXXFLAGS="$save_CXXFLAGS ${CXXFLAGS_CXX11} -I$i/ZXing" | ||
AC_CHECK_HEADER(MultiFormatWriter.h, [ZXING_CFLAGS=-I$i/ZXing; break], | ||
[unset ac_cv_header_MultiFormatWriter_h], [#include <stdexcept>]) | ||
done | ||
-- | ||
2.39.0 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters