Skip to content

Commit

Permalink
lxqt-base/lxqt-openssh-askpass: Version bump to 0.10.0
Browse files Browse the repository at this point in the history
Thanks to Alpha Bravo <[email protected]> in bug #564718
  • Loading branch information
PPed72 committed Nov 26, 2015
1 parent 30a69a2 commit c58ee4d
Showing 1 changed file with 44 additions and 0 deletions.
44 changes: 44 additions & 0 deletions lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-0.10.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit cmake-utils

DESCRIPTION="LXQt OpenSSH user password prompt tool"
HOMEPAGE="http://lxqt.org/"

if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
else
SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi

LICENSE="LGPL-2.1+"
SLOT="0"

RDEPEND="
>=dev-libs/libqtxdg-1.0.0
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
dev-qt/qtxml:5
~lxqt-base/liblxqt-${PV}
x11-libs/libX11
"
DEPEND="${RDEPEND}
dev-qt/linguist-tools:5
"

src_install(){
cmake-utils_src_install
doman man/*.1

echo "SSH_ASKPASS='${EPREFIX}/usr/bin/lxqt-openssh-askpass'" >> "${T}/99${PN}" \
|| die
doenvd "${T}/99${PN}"
}

0 comments on commit c58ee4d

Please sign in to comment.