Skip to content

Commit

Permalink
Merge branch 'gammu'
Browse files Browse the repository at this point in the history
  • Loading branch information
hartwork committed Feb 2, 2016
2 parents da4256a + 8324389 commit c5a11d3
Show file tree
Hide file tree
Showing 9 changed files with 223 additions and 5 deletions.
1 change: 1 addition & 0 deletions app-mobilephone/gammu/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gammu-1.33.0.tar.bz2 6535262 SHA256 b326223e36a334dbaed68252a9cf2d90fd898d6de4d1085dcf9c2320881aece3 SHA512 42252a36c7ad5a2945fcf23fcb1b5bb0201d27e8830d3b4a7f4c36bf00f12f5a0f7797e17098bda8d526d4ddc3b1808c0786dfae0feef9424516fa68bf2f3f1e WHIRLPOOL 27c0110da7b686bc7dd19f4f897c59d4e66aa6dbec78dec208fa8c90f70b80c1375c7b8a4b54fe40295d388de61efb11695823a503d1f85a46797c97ddf988fa
DIST gammu-1.36.8.tar.bz2 2095289 SHA256 0ed9c91b4cc5844cad04531e765bc1194cb02bc3e69e6658cd88bfb1cad74f80 SHA512 4ac86b783570db0105e18ef05fc9408e85d1234ab7de720a232a416ad867d3afbe89db7ed408c06d57f8bb38a2e272f86386f11a89e56f1d750da9e9b579ba09 WHIRLPOOL 36172cbf129647b2de48dbbe14122e71fc4f46e2f6ddb29ce546a1e37ea5c2ee0cad28ee37b29b7ddfb9605e6984c6d80d50108bfe0962417da35a1c5b2688ef
12 changes: 12 additions & 0 deletions app-mobilephone/gammu/files/gammu-1.36.8-bashcompdir.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -BurpN gammu-1.36.8.orig/contrib/CMakeLists.txt gammu-1.36.8/contrib/CMakeLists.txt
--- gammu-1.36.8.orig/contrib/CMakeLists.txt 2015-12-08 13:38:11.000000000 +0300
+++ gammu-1.36.8/contrib/CMakeLists.txt 2016-01-16 15:49:45.870431342 +0300
@@ -85,7 +85,7 @@ endif (INSTALL_PHP_EXAMPLES)
if (INSTALL_BASH_COMPLETION)
macro_optional_find_package (BashCompletion)
if (NOT BASH_COMPLETION_FOUND)
- set (BASH_COMPLETION_COMPLETIONSDIR "/etc/bash_completion.d" CACHE PATH "Location of bash_completion.d")
+ set (BASH_COMPLETION_COMPLETIONSDIR "/usr/share/bash-completion/completions" CACHE PATH "Location of bash_completion.d")
endif (NOT BASH_COMPLETION_FOUND)
install (
FILES bash-completion/gammu
79 changes: 79 additions & 0 deletions app-mobilephone/gammu/gammu-1.36.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,79 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils cmake-utils

DESCRIPTION="A tool to handle your cellular phone"
HOMEPAGE="http://wammu.eu/gammu/"
SRC_URI="http://dl.cihar.com/${PN}/releases/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bluetooth curl dbi debug irda mysql nls postgres usb"

# TODO: figure out a way to disable gudev
RDEPEND="dev-libs/glib:2=
virtual/libgudev:=
bluetooth? ( net-wireless/bluez:= )
curl? ( net-misc/curl:= )
dbi? ( >=dev-db/libdbi-0.8.3:= )
mysql? ( virtual/mysql:= )
postgres? ( dev-db/postgresql:=[server] )
usb? ( virtual/libusb:1= )
dev-util/dialog"
DEPEND="${RDEPEND}
irda? ( virtual/os-headers )
nls? ( sys-devel/gettext )"

# sys-devel/gettext is needed for creating .mo files
# Supported languages and translated documentation
# Be sure all languages are prefixed with a single space!
MY_AVAILABLE_LINGUAS=" af ar bg bn ca cs da de el en_GB es et fi fr gl he hu id it ko nl pl pt_BR ro ru sk sv sw tr zh_CN zh_TW"
IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"

src_prepare() {
epatch "${FILESDIR}/${PN}-skip-locktest.patch" \
"${FILESDIR}/${PN}-1.36.8-bashcompdir.patch"

local lang support_linguas=no
for lang in ${MY_AVAILABLE_LINGUAS} ; do
if use linguas_${lang} ; then
support_linguas=yes
break
fi
done
# install all languages when all selected LINGUAS aren't supported
if [ "${support_linguas}" = "yes" ]; then
for lang in ${MY_AVAILABLE_LINGUAS} ; do
if ! use linguas_${lang} ; then
rm -rf locale/${lang} || die
fi
done
fi
}

src_configure() {
# debug flag is used inside cmake-utils.eclass
local mycmakeargs=(
$(cmake-utils_use_with bluetooth Bluez)
$(cmake-utils_use_with irda IRDA)
$(cmake-utils_use_with curl CURL)
$(cmake-utils_use_with usb USB)
$(cmake-utils_use_with mysql MySQL)
$(cmake-utils_use_with postgres Postgres)
$(cmake-utils_use_with dbi LibDBI)
$(cmake-utils_use_with nls GettextLibs)
$(cmake-utils_use_with nls Iconv)
-DBUILD_SHARED_LIBS=ON
-DINSTALL_DOC_DIR="share/doc/${PF}"
)
cmake-utils_src_configure
}

src_test() {
LD_LIBRARY_PATH="${WORKDIR}/${PN}_build/common" cmake-utils_src_test
}
9 changes: 6 additions & 3 deletions app-mobilephone/gammu/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<use>
<flag name="irda">Enables infrared support</flag>
</use>
<use>
<flag name="irda">Enables infrared support</flag>
</use>
<upstream>
<remote-id type="github">gammu/gammu</remote-id>
</upstream>
</pkgmetadata>
66 changes: 66 additions & 0 deletions app-mobilephone/wammu/wammu-0.35-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="3"

PYTHON_DEPEND="2"

inherit distutils

DESCRIPTION="Front-end for gammu to access mobile phones easily"
HOMEPAGE="http://www.wammu.eu/"
SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bluetooth gnome"

RDEPEND=">=app-mobilephone/gammu-1.25.0[python] <app-mobilephone/gammu-1.34.0[python]
>=dev-python/wxpython-2.8
bluetooth? ( dev-python/pybluez
gnome? ( net-wireless/gnome-bluetooth )
)"
DEPEND="${RDEPEND}"

# Supported languages and translated documentation
# Be sure all languages are prefixed with a single space!
MY_AVAILABLE_LINGUAS=" af bg ca cs da de el es et fi fr gl he hu id it ko nl pl pt_BR ru sk sv zh_CN zh_TW"
IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"

pkg_setup() {
python_set_active_version 2
python_pkg_setup
}

src_prepare() {
local lang support_linguas=no
for lang in ${MY_AVAILABLE_LINGUAS} ; do
if use linguas_${lang} ; then
support_linguas=yes
break
fi
done
# install all languages when all selected LINGUAS aren't supported
if [ "${support_linguas}" = "yes" ]; then
for lang in ${MY_AVAILABLE_LINGUAS} ; do
if ! use linguas_${lang} ; then
rm -r locale/${lang} || die
fi
done
fi

python_convert_shebangs -r 2 .
}

src_compile() {
# SKIPWXCHECK: else 'import wx' results in
# Xlib: connection to ":0.0" refused by server
SKIPWXCHECK=yes distutils_src_compile
}

src_install() {
DOCS="AUTHORS FAQ"
SKIPWXCHECK=yes distutils_src_install
}
4 changes: 2 additions & 2 deletions app-mobilephone/wammu/wammu-0.36-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bluetooth gnome"

RDEPEND=">=app-mobilephone/gammu-1.25.0[python]
RDEPEND=">=app-mobilephone/gammu-1.25.0[python] <app-mobilephone/gammu-1.34.0[python]
>=dev-python/wxpython-2.8[${PYTHON_USEDEP}]
bluetooth? ( dev-python/pybluez[${PYTHON_USEDEP}]
gnome? ( net-wireless/gnome-bluetooth )
Expand Down
1 change: 1 addition & 0 deletions dev-python/python-gammu/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST python-gammu-2.5.tar.gz 133090 SHA256 871e3450a26397d555c92926382edf0e6a58431fe53613563f5a313ad752ff88 SHA512 e61bb340546cf3f98c20ff5d4ef25ca05676b4dea91e02aeee2856f091ac12fbf07a597637f9562432e298bf9678ff4445d24d8cdf96274b735aa9754b364e58 WHIRLPOOL f2ec5af883de298d71f220eb319c9df8d496328db461ba9e501e4d4d7ce150bbf19f5a07a7560804e46b21e1d848244e932f9b8eb15a60b6cf5d9a86892e45bd
20 changes: 20 additions & 0 deletions dev-python/python-gammu/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<longdescription lang="en">
Python bindings for Gammu
</longdescription>
<upstream>
<remote-id type="pypi">python-gammu</remote-id>
<remote-id type="github">gammu/python-gammu</remote-id>
</upstream>
<maintainer type="person">
<email>[email protected]</email>
<name>Andrew Wilcox</name>
<description>Proxy (user) maintainer, bugs to be assigned to him</description>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
</pkgmetadata>
36 changes: 36 additions & 0 deletions dev-python/python-gammu/python-gammu-2.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python{2_7,3_4,3_5} )

inherit distutils-r1

DESCRIPTION="Python bindings for Gammu"
HOMEPAGE="http://wammu.eu/python-gammu/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples test"

RDEPEND=">=app-mobilephone/gammu-1.34.0"
DEPEND="${RDEPEND}
virtual/pkgconfig
test? (
$(python_gen_impl_dep sqlite)
app-mobilephone/gammu[dbi]
)"

DOCS=( AUTHORS NEWS.rst README.rst )

python_test() {
esetup.py test
}

python_install_all() {
use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
}

0 comments on commit c5a11d3

Please sign in to comment.