Skip to content

Commit

Permalink
dev-db/mycli: Version bump for 1.25.0
Browse files Browse the repository at this point in the history
Signed-off-by: Brian Evans <[email protected]>
  • Loading branch information
Brian Evans committed Apr 22, 2022
1 parent fc53ab1 commit c5d6140
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/mycli/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST mycli-1.22.2_p20201026.tar.gz 269338 BLAKE2B 42f4349e65a43829691fd7fa0fa1a57968cf34ffba04156ae221d7a2713179826fc09903e45b6f05fbf05688f956a9cd95e87393179992378766b3a3a6ef9c6e SHA512 70d68d7517322b28783c324d463664c2794ba26cc78e0eee056891ce43dbce57c4dd9c13982ac2976af07ff1fa3d4552cb22bf42b9c7885c93483ba86b873636
DIST mycli-1.24.1.tar.gz 275983 BLAKE2B cc03ebd0f4de1fabbd1c186139aac04a50d01529190972cac63765a4d3e688e994c112d001489bf1dfb17541370e0c348a368d85a86b7eed335b775b96897765 SHA512 5f8ffb98fd285d2e556bef7cefdc77588983c0028c7c24084710633fb469ae3c5ab2232ca23e87406d44d87e503c113039e6884ec9efd603f45b3ab7ed7c0925
DIST mycli-1.25.0.tar.gz 277022 BLAKE2B eabb07003741bc041fcfc7be92beade5bdf0c19d0be00b1a98037d38b164043e5280254b9c8446254928253f6059c33ae9395df780a2f30c5d9cbebffe020895 SHA512 e20b1466f0f2bf81f0d65bd23f97eae6b0943029c89d9d45f84368abc5f12c3054c09a45c4daea47831a192417e2e5be7bcd6622ea518e57b68f975a028d3f79
57 changes: 57 additions & 0 deletions dev-db/mycli/mycli-1.25.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_SINGLE_IMPL=yes
inherit distutils-r1

MY_PV=$(ver_cut 1-3)
S="${WORKDIR}/${PN}-${MY_PV}"

DESCRIPTION="CLI for MySQL Database with auto-completion and syntax highlighting"
HOMEPAGE="https://www.mycli.net"
SRC_URI="https://github.com/dbcli/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="ssh"

RDEPEND="
$(python_gen_cond_dep '
>=dev-python/cli_helpers-2.2.1[${PYTHON_USEDEP}]
>=dev-python/click-7.0[${PYTHON_USEDEP}]
>=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
>=dev-python/cryptography-1.0.0[${PYTHON_USEDEP}]
>=dev-python/prompt_toolkit-3.0.0[${PYTHON_USEDEP}]
<dev-python/prompt_toolkit-4.0.0[${PYTHON_USEDEP}]
dev-python/pyaes[${PYTHON_USEDEP}]
>=dev-python/pygments-2.0[${PYTHON_USEDEP}]
>=dev-python/pymysql-0.9.2[${PYTHON_USEDEP}]
dev-python/pyperclip[${PYTHON_USEDEP}]
>=dev-python/sqlparse-0.3.0[${PYTHON_USEDEP}]
<dev-python/sqlparse-0.5.0[${PYTHON_USEDEP}]
ssh? ( dev-python/paramiko[${PYTHON_USEDEP}] )')
"
BDEPEND="
test? ( $(python_gen_cond_dep '
dev-python/mock[${PYTHON_USEDEP}]
dev-python/paramiko[${PYTHON_USEDEP}]
') )
"
distutils_enable_tests pytest

PATCHES=( "${FILESDIR}/mycli-1.21.1-fix-test-install.patch" )

python_test() {
local EPYTEST_IGNORE=(
setup.py
mycli/magic.py
mycli/packages/parseutils.py
test/features
mycli/packages/paramiko_stub/__init__.py
)
epytest --capture=sys --doctest-modules --doctest-ignore-import-errors
}

0 comments on commit c5d6140

Please sign in to comment.