forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/html2text: Bump to version 2019.8.11
Reported-by: majlo <[email protected]> Bug: https://bugs.gentoo.org/699628 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Zac Medico <[email protected]>
- Loading branch information
Showing
2 changed files
with
37 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST html2text-2018.1.9-1.tar.gz 51173 BLAKE2B a21cd3e579d47081e669fda3f3147fc28d816478885942565a1b93b86292e2729e93bfea6b5326703e575f209f5bd7dd905d72011b8153b8c40d31c83acf9057 SHA512 773b508864a2fa31e961e132118702429f5b7836e90bd521db2ed6b4215de49d63991a99b7ad7d5aac3074a3c14e4d384557a4eb5b43c7e2aada46d5434ed229 | ||
DIST html2text-2019.8.11.tar.gz 48721 BLAKE2B 6a63a9608c29374a510d7026717de4b94eb63d366513990623b9bfbf679680c85f5cf06ec7076143397d160a5c484bf5dfef3e24b1862be09e0cc0d7cd86051a SHA512 f405bccea18b2898fc8816483e8fa8912b2d508f139d7a65c54218acc87006d8b89e00a12018dc7b911f729036fe4e8a5069242dc00edb40171d4bc149e39ba6 | ||
DIST html2text-2019.9.26.tar.gz 48634 BLAKE2B efece48c7b05171f9bae833663292d7804838b5a791f1f734b3a258843a71616ada2ebee7cee406e0bfa1a3dce67040d41621bd87be100a2c0d4ca6d75829aa9 SHA512 4c6a52e96d3997a6ebe41c2955e2f6bd5189f49aadd7d7afbe67b85a2f61a0aafd0fc09fef184cb9407b9ab26f120ef235294e4e9d8f41e3b6b8f6fc29aa386d |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,36 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Turn HTML into equivalent Markdown-structured text" | ||
HOMEPAGE="https://github.com/Alir3z4/html2text https://pypi.org/project/html2text/" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~sparc ~x86" | ||
IUSE="test" | ||
RESTRICT="!test? ( test )" | ||
|
||
# pkg_resources is used for entry points | ||
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( dev-python/pytest[${PYTHON_USEDEP}] ) | ||
" | ||
|
||
DOCS=( AUTHORS.rst ChangeLog.rst README.md ) | ||
|
||
python_prepare_all() { | ||
# naming conflict with app-text/html2text, bug 421647 | ||
sed -i 's/html2text = html2text.cli:main/py\0/' setup.py || die | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_test() { | ||
pytest -vv || die "tests failed with ${EPYTHON}" | ||
} |