Skip to content

Commit

Permalink
app-editors/mg: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
ulm committed Sep 5, 2016
1 parent 60e9ffe commit c5efd92
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-editors/mg/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST mg-20150323.tar.gz 142105 SHA256 d71b24d47d3e1426f162e446d92dfa457df96dd47c1289419cba9fd14c2c3afb SHA512 747a04c203509cdbe84d9cea6c5be93585cdd5cb855b556ea5dee273a2923a4a68bee3f952cf92d584fcdd682049cb4442c21888304ba036851127174457351f WHIRLPOOL bdba74b62034a6613434fc3efea7b56fa1599b6059ab97dbd760b013be7dc50ab13dfcee3f5fb1f41f4c26c3f0146583680134d3809ec7977a14a28cb345c6db
DIST mg-20160421.tar.gz 145187 SHA256 b5dd8fbecb8a0ff0f32588c448f22f25fafcbfb297857e76d2883598a3e63a9a SHA512 7a4fb9d8958952a1b430bda88cafa251aab74691073d103941bfc2cce495ad3831b2c722db044791d61ae2aee9a5a9acaedde0090964129822c94745d89469ed WHIRLPOOL 9a040a69c9d57232c411da3859e80c84f2f250f2fd78cd2799cfb82243fdd9d01d374edb23de44d6eb94b9ab86009458b3c7c4cf34b738c45d4622e6c67dc99b
DIST mg-20160905.tar.gz 144991 SHA256 72c14476f98e341a01520f09ab8dfdd52663498d9dc14d0831c31697a08b8349 SHA512 7ee51739ef15c70e28e81b8da70d9d85534c6f5d7ddf3c8530dad8b9be73c6b519c002b219cdc782e8080fbe4cc5c09a33e6eb88b1e7b4e6771b2f5d5cff9213 WHIRLPOOL b7f17f91f366e63ae3da002af245eb66ee682748df9d7bdb53fb14cd474b44593d0e0e4f73ed26f727ec71dd39e4f3385e6bac9670b094e38fb4486f79398c09
52 changes: 52 additions & 0 deletions app-editors/mg/mg-20160905.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit toolchain-funcs

DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
HOMEPAGE="http://homepage.boetes.org/software/mg/"
SRC_URI="http://homepage.boetes.org/software/mg/${P}.tar.gz"

LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="livecd"

RDEPEND="sys-libs/ncurses:0
!elibc_FreeBSD? ( >=dev-libs/libbsd-0.7.0 )"
DEPEND="${RDEPEND}
virtual/pkgconfig"

src_prepare() {
# remove OpenBSD specific easter egg
sed -i -e 's/theo\.o//' GNUmakefile || die
sed -i -e '/theo_init/d' main.c || die

# fix path to tutorial in man page
sed -i -e "s:doc/mg/:doc/${PF}/:" mg.1 || die

eapply_user
}

src_compile() {
emake CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}" \
PKG_CONFIG="$(tc-getPKG_CONFIG)"
}

src_install() {
dobin mg
doman mg.1
dodoc README tutorial
# don't compress the tutorial, otherwise mg cannot open it
docompress -x /usr/share/doc/${PF}/tutorial
}

pkg_postinst() {
if use livecd; then
[[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
fi
}

0 comments on commit c5efd92

Please sign in to comment.