Skip to content

Commit

Permalink
dev-cpp/gtest: Fix test failure with sandbox
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/629620
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
Peter-Levine authored and floppym committed Jan 9, 2018
1 parent de6ec6b commit c611133
Show file tree
Hide file tree
Showing 3 changed files with 16 additions and 0 deletions.
14 changes: 14 additions & 0 deletions dev-cpp/gtest/files/gtest-1.8.0-increase-clone-stack-size.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
Bug: https://bugs.gentoo.org/629620
Upstream PR: https://github.com/google/googletest/pull/1274

--- a/googletest/src/gtest-death-test.cc
+++ b/googletest/src/gtest-death-test.cc
@@ -1070,7 +1070,7 @@

if (!use_fork) {
static const bool stack_grows_down = StackGrowsDown();
- const size_t stack_size = getpagesize();
+ const size_t stack_size = getpagesize() * 10;
// MMAP_ANONYMOUS is not defined on Mac, so we use MAP_ANON instead.
void* const stack = mmap(NULL, stack_size, PROT_READ | PROT_WRITE,
MAP_ANON | MAP_PRIVATE, -1, 0);
1 change: 1 addition & 0 deletions dev-cpp/gtest/gtest-1.8.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -24,6 +24,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-9999-fix-py-tests.patch
"${FILESDIR}"/${PN}-9999-fix-gcc6-undefined-behavior.patch
"${FILESDIR}"/${PN}-1.8.0-multilib-strict.patch
"${FILESDIR}"/${PN}-1.8.0-increase-clone-stack-size.patch
)

S="${WORKDIR}"/googletest-release-${PV}
Expand Down
1 change: 1 addition & 0 deletions dev-cpp/gtest/gtest-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -29,6 +29,7 @@ RDEPEND="!dev-cpp/gmock"

PATCHES=(
"${FILESDIR}"/${PN}-9999-fix-gcc6-undefined-behavior.patch
"${FILESDIR}"/${PN}-1.8.0-increase-clone-stack-size.patch
)

pkg_setup() {
Expand Down

0 comments on commit c611133

Please sign in to comment.