Skip to content

Commit

Permalink
dev-ruby/mecab-ruby: add ruby21, ruby22
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.24
  • Loading branch information
graaff committed Dec 12, 2015
1 parent 670a4b2 commit c61674d
Showing 1 changed file with 38 additions and 0 deletions.
38 changes: 38 additions & 0 deletions dev-ruby/mecab-ruby/mecab-ruby-0.996-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

USE_RUBY="ruby20 ruby21 ruby22"

inherit ruby-ng

DESCRIPTION="Ruby binding for MeCab"
HOMEPAGE="http://mecab.sourceforge.net/"
SRC_URI="https://mecab.googlecode.com/files/${P}.tar.gz"

LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE=""

DEPEND="~app-text/mecab-${PV}"
RDEPEND="${DEPEND}"

each_ruby_configure() {
${RUBY} extconf.rb || die
}

each_ruby_compile() {
emake V=1
}

each_ruby_install() {
emake DESTDIR="${D}" install
}

all_ruby_install() {
dodoc AUTHORS README test.rb
dohtml bindings.html
}

0 comments on commit c61674d

Please sign in to comment.