Skip to content

Commit

Permalink
dev-libs/libcec: Version bump to 3.x
Browse files Browse the repository at this point in the history
Bug: 554094
  • Loading branch information
whyman committed Aug 22, 2015
1 parent 30b7eaa commit c65bea6
Show file tree
Hide file tree
Showing 3 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libcec/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST libcec-2.1.3.tar.gz 1087121 SHA256 2aa88451b528184b02077ee8c6cd10e2f89121a6a05b1b35b4b792b03108a9d1 SHA512 79ddab6e1572030d860fa2ba43db7ed4ea6eb7914d3b9936c9de622f1328c1795ae3076d0c6abde193fa610a7916439f8cebdcf3bf22b59f6546ac591b4e5956 WHIRLPOOL e8400d037dee3bdb007b5e731aa794ac5dcf94ad1d4c1d1cbe39c059c77f2b2785288f3fbc987fa64eafb1dc0e2a96a9575a3cb5740edf25088c586a1b628e3d
DIST libcec-2.1.4.tar.gz 1093796 SHA256 79bef5232a5c9ab987ca3a2d4bfcaeb80480fd26f502dc1a996fe845d90fe147 SHA512 e2107b2003e003de8efea4b46a7776516652a2b27a0e0983a763324b3ac1ed2995cb0adb76e2f450bea72a1a0bdecfc5b3408fa702c74189204d694f5e9d2d8a WHIRLPOOL 4b8120755cf08dbc7ae8f2a5314f6c4e0c2ddc059b138ab594a26f7ac931cb34536a5bb2894a65902f1ba093007c1b08abeaf4306edef95059af8c85edad3e99
DIST libcec-2.2.0.tar.gz 1099150 SHA256 fd4f47a18d6e0f4b9e6f5831280207ee2b2a5fc2741ae32ae09ad12a8aa52917 SHA512 7932a45e581e207aa651e9fe72450fda52b0441fb48e40e971a530f9d5d26b87e6446322393750d85bae223519dc2a73613352a3fe42939eff2c5f8863a09cd7 WHIRLPOOL ff8581c21e280fda6333aec840cbc08fd8d23ffa795fe173076d1863c0b8fdc86fb7838c2035940dac61362ec1c74054e6e450fff7ba5426ff57a2016c6eab83
DIST libcec-3.0.1.tar.gz 1117284 SHA256 7e3670c8949a1964d6e5481f56dfff838857da10bdc60b506f6e9b7f117e253e SHA512 b579853d2d20d1007cb9128c8bb457da7c0c0138bba82fd45b05971be9c2232af6a064ab0a4f88bab10f6bda23baefffc43e717ad08b86bba3cf05c211ac5ee4 WHIRLPOOL 46583c7c8b45613a152fe37536992186a6929733dccde0399bed0cc86d07bb6e14da58ae42a12ee1ca192a2716b95b48bda9722749abfd40418b5f0f067f7a40
16 changes: 16 additions & 0 deletions dev-libs/libcec/files/libcec-3.0.1-envcheck.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
diff --git a/support/git-rev.sh b/support/git-rev.sh
index 5dce3d0..4aadae6 100755
--- a/support/git-rev.sh
+++ b/support/git-rev.sh
@@ -1,5 +1,8 @@
#!/bin/sh

## cmake doesn't read the variable when it doesn't end with a newline, and I haven't figured out how to have it add a newline directly...
-echo -n "`git --no-pager log --abbrev=7 -n 1 --pretty=format:"%h"`\n"
-
+if [ -d .git ]; then
+ echo "`git --no-pager log --abbrev=7 -n 1 --pretty=format:"%h"`"
+else
+ echo "<unknown>"
+fi

54 changes: 54 additions & 0 deletions dev-libs/libcec/libcec-3.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python2_7 python3_4 )

inherit cmake-utils eutils linux-info python-single-r1

DESCRIPTION="Library for communicating with the Pulse-Eight USB HDMI-CEC Adaptor"
HOMEPAGE="http://libcec.pulse-eight.com"
SRC_URI="http://github.com/Pulse-Eight/${PN}/archive/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~arm ~amd64 ~x86"

IUSE="cubox exynos python raspberry-pi +xrandr"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

RDEPEND="virtual/udev
dev-libs/lockdev
dev-libs/libplatform
xrandr? ( x11-libs/libXrandr )"
DEPEND="${RDEPEND}
virtual/pkgconfig
python? (
dev-lang/swig
${PYTHON_DEPS}
)"

CONFIG_CHECK="~USB_ACM"

S="${WORKDIR}/${PN}-${P}"

PATCHES=( "${FILESDIR}"/${P}-envcheck.patch )

pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_prepare() {
cmake-utils_src_prepare
use python || comment_add_subdirectory "src/pyCecClient"
}

src_configure() {
local mycmakeargs=(
$(cmake-utils_useno python SKIP_PYTHON_WRAPPER)
$(cmake-utils_use_has exynos EXYNOS_API) \
$(cmake-utils_use_has cubox TDA955X_API)
$(cmake-utils_use_has raspberry-pi RPI_API)
)
cmake-utils_src_configure
}

0 comments on commit c65bea6

Please sign in to comment.