Skip to content

Commit

Permalink
dev-ruby/activerecord: add 6.0.3.7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.2
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed May 6, 2021
1 parent 23c9133 commit c65edca
Show file tree
Hide file tree
Showing 2 changed files with 89 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/activerecord/Manifest
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
DIST rails-5.2.4.5.tgz 8826076 BLAKE2B 41a13708f72f0c281af7b6c97828d873b9431913315e155bec2f798b83a9fd214a0176a93ba74d96b48718dc900b6737a62f5d6593ef7f5bb0b8430c96e5e234 SHA512 452e0649638daf57e8f7c6131bb048c0d960e875fbc3596678404965fd1438a5151858b22c2441a927509337b6a256671b53c24ee35ff477e18153af358b08af
DIST rails-6.0.3.5.tgz 18566999 BLAKE2B b07d1d6c1e2ebaaf3c337350bb08fe339e324818543dcd7163fe3c7ff56f50c5556f369badeb4fd48afa6d95449e18e57fa1b05db6ce544d38ee2f58bd3aa513 SHA512 c9d6bf689aeb40fb728fb681b65c48ebd51de893060ddac37a1fdefbb0d420cee3a456f148d96d577c651c9d7b994efdb3319fa865cb012af8712052a20a0bf3
DIST rails-6.0.3.7.tgz 18570545 BLAKE2B 6433705f18075e286d14d25dd87def61a3ac9c7a8fc5160f37b9a6f6ab0d7f36a7235602713888df45e55cf4afb56f922c476989304397d422016dc34f147353 SHA512 91612223c9461731741c056a700879ce274a177737fd19ed6341ce07acfa4e4862728ef12bfa1a70cdb3e5c8492ad0da6aae2e7d0ed5ad32d680d8bd8c3ab102
DIST rails-6.1.2.1.tgz 10990239 BLAKE2B ff1c9781eab32fda320cb2b9efc92e52ed155b659a43385781bfa422d03653879367bedc7ef4e3accb0a51b7962054eecd5202fd1e1a49ff7946c2f9388a69df SHA512 61e8bf0568c0b06a2c8f6c5e4ae6becc521646a5cdd3d6832c3b52998326a4bd437ad2bd284c010d445a3dc54bf519f7fbd2e9d4368c91b7d2a9abe46e3a276d
DIST rails-6.1.3.1.tgz 10991507 BLAKE2B 6798364c4d8c6339269950b5b583cbaa4c6d86b7880e7fa181bb6e52bb0d18b051eec233b2819af1668dcee8c4f40765fa9c46c6bb36329d0eda19f559a7472b SHA512 8c40d739b8300eec5d054bb0481133995875fa0bf854c1f5febceba7c0d156c9f249952687f0132bbc36ac59606013625b395faa301173ecdd247b4de0bc168b
DIST rails-6.1.3.2.tgz 10992572 BLAKE2B ec4b7c33180ecc6b9dc9bd0270c9c03e48a774a7c0fc1d79638bd6b52a4c9831f59c5d8714e24c9611ac9e8ad03dddc664c2969da8be568eade76464c04d5697 SHA512 3b30facfe0555c3161b5fc50efb7dc1f3df0eeadbfa19f16df3ebdb4877d6fb9a978ae7a6713a502d79e6d8f1be20157bd5ef64919fdd558cad89492cc2d9672
Expand Down
88 changes: 88 additions & 0 deletions dev-ruby/activerecord/activerecord-6.0.3.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,88 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
USE_RUBY="ruby25 ruby26 ruby27"

# this is not null so that the dependencies will actually be filled
RUBY_FAKEGEM_TASK_TEST="test"

RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem

DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
HOMEPAGE="https://github.com/rails/rails/"
SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="mysql postgres sqlite"

RUBY_S="rails-${PV}/${PN}"

ruby_add_rdepend "~dev-ruby/activesupport-${PV}
~dev-ruby/activemodel-${PV}
sqlite? ( >=dev-ruby/sqlite3-1.4 )
mysql? ( dev-ruby/mysql2:0.5 )
postgres? ( dev-ruby/pg:1 )"

ruby_add_bdepend "
test? (
dev-ruby/bundler
~dev-ruby/actionpack-${PV}
>=dev-ruby/sqlite3-1.4.0
dev-ruby/mocha
dev-ruby/minitest:5
)"

DEPEND+=" test? ( >=dev-db/sqlite-3.12.1 )"

all_ruby_prepare() {
# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
rm ../Gemfile.lock || die
sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|execjs\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
-e '/:job/,/end/ s:^:#:' \
-e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
sed -e '/bcrypt/ s/3.0.0/3.0/' \
-i ../Gemfile || die

# Add back json in the Gemfile because we dropped some dependencies
# earlier that implicitly required it.
sed -i -e '$agem "json"' ../Gemfile || die

sed -i -e '2igem "railties", "~> 6.0.0"; gem "activemodel", "~> 6.0.0"' test/cases/helper.rb || die

# Avoid test depending on mysql adapter which we don't support for
# this Rails version to simplify our dependencies.
rm test/cases/connection_specification/resolver_test.rb || die

# Avoid single tests using mysql or postgres dependencies.
rm test/cases/invalid_connection_test.rb || die
sed -e '/test_switching_connections_with_database_url/askip "postgres"' \
-i test/cases/connection_adapters/connection_handlers_multi_db_test.rb || die

# Avoid failing test that makes bad assumptions on database state.
sed -i -e '/test_do_not_call_callbacks_for_delete_all/,/^ end/ s:^:#:' \
test/cases/associations/has_many_associations_test.rb

# Avoid test failing to bind limit length in favor of security release
sed -i -e '/test_too_many_binds/askip "Fails on Gentoo"' test/cases/bind_parameter_test.rb || die

# Avoid test failing related to rubygems
sed -i -e '/test_generates_absolute_path_with_given_root/askip "rubygems actiovation monitor"' test/cases/tasks/sqlite_rake_test.rb || die
}

each_ruby_test() {
if use sqlite; then
${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
fi
}

0 comments on commit c65edca

Please sign in to comment.