Skip to content

Commit

Permalink
dev-db/sqlite: Prefer eapply over epatch in EAPI-6 ebuilds.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
Lars Wendler committed Nov 29, 2016
1 parent 982d554 commit c678c2c
Show file tree
Hide file tree
Showing 7 changed files with 21 additions and 21 deletions.
4 changes: 2 additions & 2 deletions dev-db/sqlite/files/sqlite-3.12.0-nonfull_tarball-build.patch
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
Fix building with dlopen() not available.

--- configure.ac
+++ configure.ac
--- a/configure.ac
+++ b/configure.ac
@@ -89,6 +89,9 @@
[], [enable_dynamic_extensions=yes])
if test x"$enable_dynamic_extensions" != "xno"; then
Expand Down
8 changes: 4 additions & 4 deletions dev-db/sqlite/files/sqlite-3.13.0-full_tarball-build.patch
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,8 @@ Link executables against libsqlite3.so.
Increase timeout for fuzzcheck.
Fix building with dlopen() not available.

--- Makefile.in
+++ Makefile.in
--- a/Makefile.in
+++ b/Makefile.in
@@ -555,7 +555,7 @@
# Extra compiler options for various shell tools
#
Expand Down Expand Up @@ -123,8 +123,8 @@ Fix building with dlopen() not available.

loadfts$(EXE): $(TOP)/tool/loadfts.c libsqlite3.la
$(LTLINK) $(TOP)/tool/loadfts.c libsqlite3.la -o $@ $(TLIBS)
--- configure.ac
+++ configure.ac
--- a/configure.ac
+++ b/configure.ac
@@ -570,6 +570,9 @@
if test "${use_loadextension}" = "yes" ; then
OPT_FEATURE_FLAGS=""
Expand Down
8 changes: 4 additions & 4 deletions dev-db/sqlite/files/sqlite-3.14.0-full_tarball-build.patch
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,8 @@ Link executables against libsqlite3.so.
Increase timeout for fuzzcheck.
Fix building with dlopen() not available.

--- Makefile.in
+++ Makefile.in
--- a/Makefile.in
+++ b/Makefile.in
@@ -559,6 +559,7 @@
#
SHELL_OPT = -DSQLITE_ENABLE_JSON1 -DSQLITE_ENABLE_FTS4
Expand Down Expand Up @@ -133,8 +133,8 @@ Fix building with dlopen() not available.

loadfts$(EXE): $(TOP)/tool/loadfts.c libsqlite3.la
$(LTLINK) $(TOP)/tool/loadfts.c libsqlite3.la -o $@ $(TLIBS)
--- configure.ac
+++ configure.ac
--- a/configure.ac
+++ b/configure.ac
@@ -584,6 +584,9 @@
if test "${use_loadextension}" = "yes" ; then
OPT_FEATURE_FLAGS=""
Expand Down
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
https://www.sqlite.org/src/info/afbbb6c66a85ff3f

--- ext/icu/icu.c
+++ ext/icu/icu.c
--- a/ext/icu/icu.c
+++ b/ext/icu/icu.c
@@ -500,20 +500,20 @@
void *pContext; /* sqlite3_user_data() context */
void (*xFunc)(sqlite3_context*,int,sqlite3_value**);
Expand Down Expand Up @@ -34,8 +34,8 @@ https://www.sqlite.org/src/info/afbbb6c66a85ff3f

{"icu_load_collation", 2, SQLITE_UTF8, (void*)db, icuLoadCollation},
};
--- test/cursorhint2.test
+++ test/cursorhint2.test
--- a/test/cursorhint2.test
+++ b/test/cursorhint2.test
@@ -164,17 +164,19 @@
x2 {AND(EQ(c1,ADD(32,32)),EQ(c0,r[2]))}
}
Expand Down
4 changes: 2 additions & 2 deletions dev-db/sqlite/sqlite-3.14.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -50,15 +50,15 @@ pkg_setup() {

src_prepare() {
if full_tarball; then
epatch "${FILESDIR}/${PN}-3.14.0-full_tarball-build.patch"
eapply "${FILESDIR}/${PN}-3.14.0-full_tarball-build.patch"

eapply_user

# Fix AC_CHECK_FUNCS.
# https://mailinglists.sqlite.org/cgi-bin/mailman/private/sqlite-dev/2016-March/002762.html
sed -e "s/AC_CHECK_FUNCS(.*)/AC_CHECK_FUNCS([fdatasync fullfsync gmtime_r isnan localtime_r localtime_s malloc_usable_size posix_fallocate pread pread64 pwrite pwrite64 strchrnul usleep utime])/" -i configure.ac || die "sed failed"
else
epatch "${FILESDIR}/${PN}-3.12.0-nonfull_tarball-build.patch"
eapply "${FILESDIR}/${PN}-3.12.0-nonfull_tarball-build.patch"

eapply_user

Expand Down
4 changes: 2 additions & 2 deletions dev-db/sqlite/sqlite-3.14.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -50,15 +50,15 @@ pkg_setup() {

src_prepare() {
if full_tarball; then
epatch "${FILESDIR}/${PN}-3.14.0-full_tarball-build.patch"
eapply "${FILESDIR}/${PN}-3.14.0-full_tarball-build.patch"

eapply_user

# Fix AC_CHECK_FUNCS.
# https://mailinglists.sqlite.org/cgi-bin/mailman/private/sqlite-dev/2016-March/002762.html
sed -e "s/AC_CHECK_FUNCS(.*)/AC_CHECK_FUNCS([fdatasync fullfsync gmtime_r isnan localtime_r localtime_s malloc_usable_size posix_fallocate pread pread64 pwrite pwrite64 strchrnul usleep utime])/" -i configure.ac || die "sed failed"
else
epatch "${FILESDIR}/${PN}-3.12.0-nonfull_tarball-build.patch"
eapply "${FILESDIR}/${PN}-3.12.0-nonfull_tarball-build.patch"

eapply_user

Expand Down
6 changes: 3 additions & 3 deletions dev-db/sqlite/sqlite-3.15.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -50,16 +50,16 @@ pkg_setup() {

src_prepare() {
if full_tarball; then
epatch "${FILESDIR}/${PN}-3.14.0-full_tarball-build.patch"
epatch "${FILESDIR}/${PN}-3.15.0-full_tarball-tests-icu.patch"
eapply "${FILESDIR}/${PN}-3.14.0-full_tarball-build.patch"
eapply "${FILESDIR}/${PN}-3.15.0-full_tarball-tests-icu.patch"

eapply_user

# Fix AC_CHECK_FUNCS.
# https://mailinglists.sqlite.org/cgi-bin/mailman/private/sqlite-dev/2016-March/002762.html
sed -e "s/AC_CHECK_FUNCS(.*)/AC_CHECK_FUNCS([fdatasync fullfsync gmtime_r isnan localtime_r localtime_s malloc_usable_size posix_fallocate pread pread64 pwrite pwrite64 strchrnul usleep utime])/" -i configure.ac || die "sed failed"
else
epatch "${FILESDIR}/${PN}-3.12.0-nonfull_tarball-build.patch"
eapply "${FILESDIR}/${PN}-3.12.0-nonfull_tarball-build.patch"

eapply_user

Expand Down

0 comments on commit c678c2c

Please sign in to comment.