forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ros/ament_cmake_cpplint: bump to 0.10.4
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alexis Ballier <[email protected]>
- Loading branch information
Showing
2 changed files
with
63 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST ament_lint-0.10.0.tar.gz 219525 BLAKE2B 6ba7a32d0678e545c24b74ed187991140c34a363ad855e469f0e20f8a088b7cc939bbd187566233e099576e4c2b899d7d75edf311d3026234222078968be7ce6 SHA512 565413fa325317e6f00ce18051eb13556d1d50144d2c8f62368e5505455ef7f9fae3a69e8d723a3949e44b1f9e638741ae6d9b87687df81a661eb804365200f8 | ||
DIST ament_lint-0.10.1.tar.gz 221215 BLAKE2B 47ffa7dfd892b05f345ba962c7c08dcf1627c4653cc75e1a1d1cad28971974ef5ca9c09d3989b3fdbfacd7f94dace9651c44911cd7747f39c5c59083f0195443 SHA512 1dd996d86cfb7488bd6bf57510eb5b7531fe4fe21d25203a4801046ec719ba19afdb89eb7ba9d862317d2e041e7139fadde27d114614d96741a177e8ec2a2ba3 | ||
DIST ament_lint-0.10.4.tar.gz 222285 BLAKE2B 81a15dc996bad0fe3fa461aa7067eba423550d94a04881a12c8a4b0732a4a0ddcc30ab6bef94f81cb236836d8de7959b53d5560d5fb6eb480f2fbd849bd02489 SHA512 cb99084622f598b17f1ffe55620c9c822867771f2603e673098f8943d95b7be188e25480d4e22bf7c2988e94d8b69f6f7fa3b60cd042213f6bd8c2ad2c5deaf3 | ||
DIST ament_lint-0.9.5.tar.gz 218077 BLAKE2B bc49fdb517bcdab815cfd4c945e9d61a9b53d4b600361ced9161b6186bfb74fdb3d5ed5f14a48f22a91fd0737333dc76cc7d55044c204ea864b53dd68e32254b SHA512 1c5b3acb31a07f4613e13fe69f6dad1981df0dc596e46a07651322a4da1c5f3db40befb775aa42aabc1f6808132c950c9f37950f64b4196e3c1b40871e25a384 |
62 changes: 62 additions & 0 deletions
62
dev-ros/ament_cmake_cpplint/ament_cmake_cpplint-0.10.4.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,62 @@ | ||
# Copyright 2019-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python{3_7,3_8} ) | ||
|
||
inherit cmake python-any-r1 | ||
|
||
ROS_PN="ament_lint" | ||
if [ "${PV#9999}" != "${PV}" ] ; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://github.com/ament/ament_lint" | ||
SRC_URI="" | ||
S=${WORKDIR}/${P}/${PN} | ||
else | ||
SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz" | ||
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}" | ||
fi | ||
|
||
DESCRIPTION="CMake API for ament_cpplint to lint C / C++ code using cpplint" | ||
HOMEPAGE="https://github.com/ament/ament_lint" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
if [ "${PV#9999}" != "${PV}" ] ; then | ||
KEYWORDS="" | ||
else | ||
KEYWORDS="~amd64" | ||
fi | ||
IUSE="test" | ||
RESTRICT="!test? ( test )" | ||
|
||
RDEPEND=" | ||
dev-ros/ament_cmake_test | ||
dev-ros/ament_cpplint | ||
" | ||
DEPEND="" | ||
BDEPEND=" | ||
$(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]') | ||
dev-ros/ament_cmake_test | ||
dev-ros/ament_cmake_core | ||
test? ( | ||
dev-ros/ament_cmake_copyright | ||
$(python_gen_any_dep 'dev-ros/ament_copyright[${PYTHON_USEDEP}]') | ||
dev-ros/ament_cmake_lint_cmake | ||
) | ||
${PYTHON_DEPS} | ||
" | ||
|
||
python_check_deps() { | ||
{ use !test || has_version -b "dev-ros/ament_copyright[${PYTHON_USEDEP}]"; } && \ | ||
has_version -b "dev-python/catkin_pkg[${PYTHON_USEDEP}]" && \ | ||
has_version -b "dev-python/ament_package[${PYTHON_USEDEP}]" | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBUILD_TESTING=$(usex test ON OFF) | ||
) | ||
cmake_src_configure | ||
} |