Skip to content

Commit

Permalink
media-sound/gimmix: Fix format-security warning (bug #542140)
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
nyxdis committed Sep 20, 2015
1 parent 96b0c16 commit c6c3843
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
13 changes: 13 additions & 0 deletions media-sound/gimmix/files/gimmix-0.5.7.2-format-security.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
diff --git a/src/gimmix-config.c b/src/gimmix-config.c
index 3ef4e48..821a427 100644
--- a/src/gimmix-config.c
+++ b/src/gimmix-config.c
@@ -146,7 +146,7 @@ gimmix_config_get_proxy_string (void)
}
else
{
- ret = g_strdup_printf (host);
+ ret = g_strdup (host);
}
}

44 changes: 44 additions & 0 deletions media-sound/gimmix/gimmix-0.5.7.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=4
inherit autotools eutils

DESCRIPTION="a graphical music player daemon (MPD) client using GTK+2"
HOMEPAGE="https://launchpad.net/gimmix"
SRC_URI="mirror://gentoo/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="cover lyrics taglib"

RDEPEND=">=media-libs/libmpd-0.17
gnome-base/libglade
x11-libs/gtk+:2
cover? ( net-libs/libnxml net-misc/curl )
lyrics? ( net-libs/libnxml net-misc/curl )
taglib? ( >=media-libs/taglib-1.5 )"
DEPEND="${RDEPEND}
virtual/pkgconfig
dev-util/intltool"

DOCS=( AUTHORS ChangeLog README TODO )

src_prepare() {
epatch "${FILESDIR}"/${PN}-0.5.7.1-curl-headers.patch \
"${FILESDIR}"/${P}-format-security.patch
sed -i -e "/^Icon/s/\.png$//" \
-e "/^Categories/s/Application;//" data/gimmix.desktop

# broken build system in tarball
eautoreconf
}

src_configure() {
econf \
$(use_enable cover) \
$(use_enable lyrics) \
$(use_enable taglib tageditor)
}

0 comments on commit c6c3843

Please sign in to comment.