Skip to content

Commit

Permalink
dev-python/setuptools: Bump to 60.0.2
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Dec 20, 2021
1 parent 6ef577a commit c6d2f99
Show file tree
Hide file tree
Showing 2 changed files with 88 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/setuptools/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -7,3 +7,4 @@ DIST setuptools-59.5.0.tar.gz 2281671 BLAKE2B 51b3435a1d7962a06f7cf07c31487a1404
DIST setuptools-59.6.0.tar.gz 2281973 BLAKE2B 1e7ffc94626684f7e82a1bbba14889af052898f87f79205618fb76d78252397d3fb555778cb3920d2eed55bc1ee2c95ceec9206940269a4ba35b3bc44eb91226 SHA512 25472ec7c167e07113c6645880952458969b146766b64224ec8f40dfc2a29b23e47104b63e806292ec81ee4e9dbbdc4663228f39b4412b586cba644f69b52309
DIST setuptools-59.8.0.tar.gz 2282358 BLAKE2B 2f1b49285fc70420e24f958c4955200ef0407a7f3aa52fd581a165fd47c7bbde8366c26963f1bbb36f0f77797c12cbb9016fdc69e1a5cc696bb67aacca16d140 SHA512 d906558b498bda8abf28831224502c6f0290a4cdbf087fe07af8321dba3dfd1e19fa5b4a820033e54c4561b82ea8ec54c287b4fd657892ed28c2a7de91a9107e
DIST setuptools-60.0.0.tar.gz 2282339 BLAKE2B ad9a78df348c71d4374ccd773495cc3bfd6d02c214a327eece5daea06538c6a7a55975b22175afb6e67692a0945a7d48cd7b317040c7b5c4878a030505d5dbb1 SHA512 088c3dc38485ca16441d38e3404bce7d822f3ef8e48588101e9e93209905d8b1e1676de1131e2fd993a95caed0fcb3681386fbb7b679712ad0632cdbbcc04f51
DIST setuptools-60.0.2.tar.gz 2284789 BLAKE2B b3763673e65ae7e6e7d8d2e7bb5d4b72e348a873496d5d0ffdb85daa2a65280fdd71be411132ee92717fd5f3437e10c36d244b0389d0a845b8f1ecd6f2094514 SHA512 1323c5993fcb1d8f23c6fc88d217af59d08d0130d06e84d38f0ac5ed6e3bf6d5595027a8f9430f3441d9a065686562d79b413ed32771276410a31f3addcde116
87 changes: 87 additions & 0 deletions dev-python/setuptools/setuptools-60.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,87 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
EAPI=7

# Set to 'manual' to avoid triggering install QA check
DISTUTILS_USE_SETUPTOOLS=manual
PYTHON_COMPAT=( python3_{8..10} pypy3 )
PYTHON_REQ_USE="xml(+)"

inherit distutils-r1 multiprocessing

CPY_PATCHSET="python-gentoo-patches-3.10.0_p1"
DESCRIPTION="Collection of extensions to Distutils"
HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
https://dev.gentoo.org/~floppym/python/${CPY_PATCHSET}.tar.xz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"

BDEPEND="
test? (
$(python_gen_cond_dep '
dev-python/jaraco-envs[${PYTHON_USEDEP}]
>=dev-python/jaraco-path-3.2.0[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pip[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
>=dev-python/virtualenv-20[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
' python3_{8..10} pypy3)
)
"
PDEPEND="
>=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]
dev-python/setuptools_scm[${PYTHON_USEDEP}]"

# Force in-source build because build system modifies sources.
DISTUTILS_IN_SOURCE_BUILD=1

DOCS=( {CHANGES,README}.rst )

src_prepare() {
# apply distutils patches to the bundled distutils
pushd setuptools/_distutils >/dev/null || die
# TODO: distutils C++ patch?
eapply -p3 "${WORKDIR}/${CPY_PATCHSET}/0006-distutils-make-OO-enable-both-opt-1-and-opt-2-optimi.patch"
popd >/dev/null || die

distutils-r1_src_prepare
}

python_test() {
# keep in sync with python_gen_cond_dep above!
has "${EPYTHON}" python3.{8..10} pypy3 || continue

distutils_install_for_testing
local EPYTEST_DESELECT=(
# network
setuptools/tests/test_distutils_adoption.py
'setuptools/tests/test_virtualenv.py::test_pip_upgrade_from_source[None]'
# unhappy with pytest-xdist?
setuptools/tests/test_easy_install.py::TestUserInstallTest::test_local_index
# TODO
setuptools/tests/test_easy_install.py::TestSetupRequires::test_setup_requires_with_allow_hosts
setuptools/tests/test_test.py::test_tests_are_run_once
)

# test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
# It tries to sandbox the test in a tempdir
HOME="${PWD}" epytest \
-n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" setuptools
}

python_install() {
export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
distutils-r1_python_install
}

0 comments on commit c6d2f99

Please sign in to comment.