Skip to content

Commit

Permalink
gnome-extra/gucharmap: Version bump to 14.0.1
Browse files Browse the repository at this point in the history
  • Loading branch information
mattst88 committed Dec 17, 2021
1 parent df72ab3 commit c71c164
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-extra/gucharmap/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gucharmap-13.0.8.tar.gz 1920107 BLAKE2B 247b6683358e1fcbba02cad8146b8b1e7a4ccd5e56d3f9c6e597b47bcd38d11759a02e60d5635c3f2e26defe166b6e4ded696b5d1f6e1be6564d6139e3ed1ab8 SHA512 15eacbf351c8b2357e59913e5b4cccd279aed7a492351c42101dd26020658f2f4d7aaff2a3b95ca340a73606592f47edf9645c93234afb1a086362ef32904bcf
DIST gucharmap-14.0.1.tar.gz 1925102 BLAKE2B 134d48703efb27d5eb3a19e8d90031d6feb8f0fa7321596efc1209377653590fe5f4191af739f012c1dee15df75e2d70ca2ed8850d30b57cc87b97343716de85 SHA512 5a79afe1a7e9f2a54f7499a578a34db690853f096a9374b335786abd3439812f511222792447f6cc603c2611490d3514d6a179844dd03fbf7f289133e29cf015
DIST gucharmap-3.0.1.tar.bz2 3275481 BLAKE2B 80dde7791abdc72677add9c65c59f810e6c6952116b92db34059c4c40d2657246b17844c105e68f32c86294e9b4e71e9d48e6f0522855465734d7c24e8d17608 SHA512 4d8a2276b5cb1a0b0fadca2a8522755c5884985a12d5b19341b9cefcd7f749ec1286c0271419e38ec84be7edcfa1293e7f0263eb682c75387d692792de3e1fb1
66 changes: 66 additions & 0 deletions gnome-extra/gucharmap/gucharmap-14.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
VALA_MIN_API_VERSION="0.26"
VALA_USE_DEPEND="vapigen"

inherit gnome2-utils meson python-any-r1 vala xdg

DESCRIPTION="Unicode character map viewer and library"
HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.gz"

LICENSE="GPL-3+"
SLOT="2.90"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"

UNICODE_VERSION="14.0"

IUSE="debug +introspection gtk-doc vala"
REQUIRED_USE="vala? ( introspection )"

BDEPEND="
${PYTHON_DEPS}
virtual/pkgconfig
>=sys-devel/gettext-0.19.8
gtk-doc? ( >=dev-util/gtk-doc-1 )
introspection? ( >=dev-libs/gobject-introspection-1.54:= )
vala? ( $(vala_depend) )"

DEPEND="=app-i18n/unicode-data-${UNICODE_VERSION}*
>=dev-libs/glib-2.32:2
media-libs/freetype:2
>=dev-libs/libpcre2-10.21:=
>=x11-libs/gtk+-3.22:3[introspection?]
>=x11-libs/pango-1.42.4-r2[introspection?]"

RDEPEND="${DEPEND}"

src_prepare() {
use vala && vala_src_prepare
xdg_src_prepare
}

src_configure() {
local emesonargs=(
-Ducd_path="${EPREFIX}/usr/share/unicode-data"
$(meson_use debug dbg)
$(meson_use gtk-doc docs)
$(meson_use introspection gir)
$(meson_use vala vapi)
)

meson_src_configure
}

pkg_postinst() {
xdg_pkg_postinst
gnome2_schemas_update
}

pkg_postrm() {
xdg_pkg_postrm
gnome2_schemas_update
}

0 comments on commit c71c164

Please sign in to comment.