Skip to content

Commit

Permalink
sys-cluster/kubectl: Version bump to 1.7.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
mrueg committed Aug 21, 2017
1 parent b34ef03 commit c71d837
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-cluster/kubectl/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kubernetes-1.7.3.tar.gz 22019646 SHA256 7f84e08c2944865247c3fee26b010452e4a315a1cdd7983ff59d151f17167b13 SHA512 9c239cff3c3a18cc384079599abcffd7475052cff0d237e7b5b298229e08dea083c47284470ed5158484c9611c029aecca496391730793251389d05ce86d4146 WHIRLPOOL 35e6aaf16d9d411865e0ca594373fd08178d78899e06b1bbea7ef494b8e94264068700eb498684d54e665385b515055f4dca6df4345dfecff073afbd98bfe645
DIST kubernetes-1.7.4.tar.gz 22025821 SHA256 a480c54f3108f9a7ff118d90a0a16be52ecd34dcdb786f6c5d287d5298da64f0 SHA512 78404f7e6cfa6a4b599bf76373d59c799040c42ad8ce8abf259f2468eeaa07cb31514e32bd6577985087bebafe50da0baf3d0e7e9e0958a9f6250c6dade450f9 WHIRLPOOL 097d8ad32ee1c5618d5d6e01e0549c982dfacb20467ac7bc87c04cb0b5fb1361bf2ae196da07aa0832b04cc07f20bcde29a7c104a7ebb383bc4a6f8df6d538f4
46 changes: 46 additions & 0 deletions sys-cluster/kubectl/kubectl-1.7.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit golang-build golang-vcs-snapshot bash-completion-r1

EGO_PN="k8s.io/kubernetes"
ARCHIVE_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="CLI to run commands against Kubernetes clusters"
HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
SRC_URI="${ARCHIVE_URI}"

LICENSE="Apache-2.0"
SLOT="0"
IUSE=""

DEPEND="dev-go/go-bindata"

RESTRICT="test"

src_prepare() {
default
sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" src/${EGO_PN}/hack/lib/golang.sh || die
sed -i -e "/export PATH/d" src/${EGO_PN}/hack/generate-bindata.sh || die
}

src_compile() {
LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -j1 -C src/${EGO_PN} WHAT=cmd/${PN}
pushd src/${EGO_PN} || die
_output/bin/${PN} completion bash > ${PN}.bash
_output/bin/${PN} completion zsh > ${PN}.zsh
popd || die
}

src_install() {
pushd src/${EGO_PN} || die
dobin _output/bin/${PN}

newbashcomp ${PN}.bash ${PN}
insinto /usr/share/zsh/site-functions
newins ${PN}.zsh ${PN}

popd || die
}

0 comments on commit c71d837

Please sign in to comment.