Skip to content

Commit

Permalink
dev-python/zope-component: Bump to 5.1.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jan 4, 2023
1 parent 169d399 commit c724c55
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/zope-component/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST zope.component-5.0.1.tar.gz 91130 BLAKE2B 4dbd78b003ba3688c0468573f4552c87333fd5fb7e0cd89d4844633f28c19443b3ea884438ff7f7ba8b056790f008c246c1e7ad52403d7b72b146d0d53edd8ad SHA512 fad011816fe5bb869bb2e43e11a66841a6be2abf9002e41207ef1dfe69b1afb5ca486d275daeddf71d2a0e79e1a9c839c4735190dddcd118b675a976bde07a64
DIST zope.component-5.1.0.tar.gz 90238 BLAKE2B 411f1704f3e4c9a716508595ef75f1908b757f776b0ebe7677e38e678eb13e2cd5579441b94082e504f2dbc05c41e49fe0e2d1dcad406baafbc6b0733cb85008 SHA512 6695365b0313a24184d0d3b6e10ce0eda108e3e832c97709a4285bf1e76289a71223611d930a4cc3d3b5c2c766a5cfddb3cf616a64848eeccc6f3ac09316f3d1
56 changes: 56 additions & 0 deletions dev-python/zope-component/zope-component-5.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )

inherit distutils-r1

MY_PN=zope.component
MY_P=${MY_PN}-${PV}
DESCRIPTION="Zope Component Architecture"
HOMEPAGE="
https://pypi.org/project/zope.component/
https://github.com/zopefoundation/zope.component/
"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
S=${WORKDIR}/${MY_P}

LICENSE="ZPL"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"

RDEPEND="
dev-python/zope-event[${PYTHON_USEDEP}]
>=dev-python/zope-hookable-4.2.0[${PYTHON_USEDEP}]
>=dev-python/zope-interface-5.3.0[${PYTHON_USEDEP}]
!dev-python/namespace-zope
"
BDEPEND="
test? (
dev-python/zope-configuration[${PYTHON_USEDEP}]
dev-python/zope-i18nmessageid[${PYTHON_USEDEP}]
dev-python/zope-testing[${PYTHON_USEDEP}]
)
"

distutils_enable_tests unittest

src_prepare() {
# strip rdep specific to namespaces
sed -i -e "/'setuptools'/d" setup.py || die
distutils-r1_src_prepare
}

python_compile() {
distutils-r1_python_compile
find "${BUILD_DIR}" -name '*.pth' -delete || die
}

python_test() {
cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
distutils_write_namespace zope
eunittest
}

0 comments on commit c724c55

Please sign in to comment.