Skip to content

Commit

Permalink
app-editors/retext: Update live ebuild
Browse files Browse the repository at this point in the history
Signed-off-by: Nils Freydank <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Closes: gentoo#10166
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
holgersson32644 authored and mgorny committed Nov 22, 2018
1 parent f801fe7 commit c726bf6
Showing 1 changed file with 24 additions and 17 deletions.
41 changes: 24 additions & 17 deletions app-editors/retext/retext-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,13 +1,13 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python3_{4,5,6} )
# no pypy{,3} support as PyQt5 does not support it at 2018-11-18
# https://bitbucket.org/pypy/compatibility/wiki/Home#!gui-library-bindings
PYTHON_COMPAT=( python3_{4,5,6,7} )

PLOCALES="ca cs cy da de es et eu fr hu it ja pl pt pt_BR ru sk sr sr@latin uk zh_TW"

inherit distutils-r1 virtualx l10n xdg-utils
inherit distutils-r1 gnome2-utils virtualx xdg-utils

MY_PN="ReText"
MY_P="${MY_PN}-${PV/_/~}"
Expand All @@ -25,38 +25,45 @@ if [[ ${PV} == *9999 ]]
S="${WORKDIR}"/${MY_P}
fi

LICENSE="GPL-2"
LICENSE="GPL-2+"
SLOT="0"
IUSE="+spell"

RDEPEND="
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/markdown[${PYTHON_USEDEP}]
>=dev-python/markups-2.0[${PYTHON_USEDEP}]
>=dev-python/chardet-2.3[${PYTHON_USEDEP}]
dev-python/markups[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/python-markdown-math[${PYTHON_USEDEP}]
dev-python/PyQt5[gui,network,printsupport,webengine,widgets,${PYTHON_USEDEP}]
spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )
"
DEPEND="
${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( x11-base/xorg-server[xvfb] )
"

remove_locale() {
find "${ED}" -name "retext_${1}.qm" -delete || die "Failed to remove locale ${1}."
src_test() {
virtx distutils-r1_src_test
}

python_test() {
virtx esetup.py test
}

python_install_all() {
distutils-r1_python_install_all

l10n_for_each_disabled_locale_do remove_locale
esetup.py test
}

pkg_postinst() {
xdg_desktop_database_update
gnome2_icon_cache_update

einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."
einfo "For more details take a look at:"
einfo "https://github.com/mitya57/python-markdown-math#math-delimiters"
}

pkg_postrm() {
gnome2_icon_cache_update
xdg_desktop_database_update
}

0 comments on commit c726bf6

Please sign in to comment.