forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/backports-unittest-mock: needed as a new dep to test dev-p…
…ython/irc Package-Manager: portage-2.2.26
- Loading branch information
Showing
3 changed files
with
53 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST backports.unittest_mock-1.1.1.tar.gz 3255 SHA256 641bd99befaa09834df2aa5f01a0db27c782758e06d46831bfae6ff91dc5d1be SHA512 82872d9ada74b7e64792b29cd49177d5c54ffd64260ce17628df7df08e9e16ee1456d9f80eacacebb43a5e51ad93868cd49bee84209cf6682385e746bcfc90c4 WHIRLPOOL e1c1728a6a2aa0a2ec58a57b23874deb1167d2e3599a20d5e1331ab97e34798519956cb5b20bed735c7a714b6d258944f32144997a9763462c3d373e28a68267 |
38 changes: 38 additions & 0 deletions
38
dev-python/backports-unittest-mock/backports-unittest-mock-1.1.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
# It is the developer's intention that backports.unittest_mock will be | ||
# used even for Python 3: https://github.com/jaraco/jaraco.timing/pull/1 | ||
PYTHON_COMPAT=( python{2_7,3_4,3_5} ) | ||
|
||
inherit distutils-r1 | ||
|
||
MY_PN="${PN/-/.}" | ||
MY_PN="${MY_PN//-/_}" | ||
DESCRIPTION="Backport of unittest.mock" | ||
HOMEPAGE="https://github.com/jaraco/backports.unittest_mock" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="test" | ||
|
||
RDEPEND="dev-python/mock[${PYTHON_USEDEP}]" | ||
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}] | ||
>=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}] | ||
test? ( | ||
${RDEPEND} | ||
>=dev-python/pytest-2.8[${PYTHON_USEDEP}] | ||
dev-python/pytest-runner[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
S="${WORKDIR}/${MY_PN}-${PV}" | ||
|
||
python_test() { | ||
py.test || die "tests failed with ${EPYTHON}" | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,14 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<herd>proxy-maintainers</herd> | ||
<maintainer> | ||
<email>[email protected]</email> | ||
<name>Louis Sautier</name> | ||
<description>Proxied maintainer; set to assignee in all bugs</description> | ||
</maintainer> | ||
<upstream> | ||
<remote-id type="pypi">backports.unittest_mock</remote-id> | ||
<remote-id type="github">jaraco/backports.unittest_mock</remote-id> | ||
</upstream> | ||
</pkgmetadata> |