forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/buildbot-waterfall-view: Version Bump
Package-Manager: portage-2.3.0
- Loading branch information
Showing
2 changed files
with
46 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST buildbot-waterfall-view-0.9.0rc1.tar.gz 701353 SHA256 8822f75ceac242d00dc10cdc381864e460b936532a1618bf47ce9b353a63814a SHA512 3829faf9da4fb8a2137affbafc0fc4e08e3bfd229a861089e1140e715348305896235dfeb44df93b4b8da3273f261b1d98e02073d4b822c99c4eec7736824def WHIRLPOOL e616ab438b5d64a63ee33cf47475bb35869c27e9b277797ef99a246f72a95339eb8145afed1b18f412d2212be0292c6bae63f4741a7f1611d95529f67d8cae98 | ||
DIST buildbot-waterfall-view-0.9.0rc2.tar.gz 701480 SHA256 00cc9d74d18d1e7b59a303884bfa3519e315fe580cd938ff489b5eafd7cacbff SHA512 a3bd896b529666b51b0b9c34fca612172b98c20cec34f4d508a5fb7d33d9ba6d3caf9b59c7ede059532b31848fa66ed5a66b807037ecf7da7291f3ad9e2a454c WHIRLPOOL a32e6b2a5c5ef9591a09654bd487eb3e7df5652a3dd1efa86ad98478fa5a7d7deadb945b5a50c708b98d151c6112c0733bfaafc3fcc23ffcd6daccbdeb5912fc |
45 changes: 45 additions & 0 deletions
45
dev-util/buildbot-waterfall-view/buildbot-waterfall-view-0.9.0_rc2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
PYTHON_REQ_USE="sqlite" | ||
PYTHON_COMPAT=( python2_7 ) | ||
|
||
EGIT_REPO_URI="git://github.com/buildbot/buildbot.git" | ||
|
||
[[ ${PV} == *9999 ]] && inherit git-r3 | ||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Buildbot waterfall-view plugin" | ||
HOMEPAGE="http://trac.buildbot.net/ https://github.com/buildbot/buildbot http://pypi.python.org/pypi/buildbot" | ||
|
||
MY_V="0.9.0rc2" | ||
MY_P="${PN}-${MY_V}" | ||
[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
|
||
if [[ ${PV} == *9999 ]]; then | ||
KEYWORDS="" | ||
else | ||
KEYWORDS="~amd64" | ||
fi | ||
|
||
RDEPEND=" | ||
~dev-util/buildbot-${PV}[${PYTHON_USEDEP}] | ||
dev-python/mock[${PYTHON_USEDEP}] | ||
~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}] | ||
" | ||
|
||
DEPEND="${RDEPEND} | ||
>=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}] | ||
" | ||
|
||
S="${WORKDIR}/${MY_P}" | ||
#[[ ${PV} == *9999 ]] && S=${S}/www/base | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all | ||
} |