Skip to content

Commit

Permalink
dev-games/openscenegraph: add patch to support giflib5, bug 571656
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
reavertm committed Jan 13, 2016
1 parent 0b20a40 commit c775cf1
Show file tree
Hide file tree
Showing 2 changed files with 25 additions and 0 deletions.
24 changes: 24 additions & 0 deletions dev-games/openscenegraph/files/openscenegraph-3.2.1-giflib5.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
From: Alberto Luaces <[email protected]>
Date: Sat, 19 Dec 2015 04:52:52 +0100
Subject: Compatibility with giflib5.

---
OpenSceneGraph/src/osgPlugins/gif/ReaderWriterGIF.cpp | 4 ++++
1 file changed, 4 insertions(+)

Index: git2/OpenSceneGraph/src/osgPlugins/gif/ReaderWriterGIF.cpp
===================================================================
--- git2.orig/OpenSceneGraph/src/osgPlugins/gif/ReaderWriterGIF.cpp
+++ git2/OpenSceneGraph/src/osgPlugins/gif/ReaderWriterGIF.cpp
@@ -561,7 +561,11 @@ GifImageStream** obj)
*width_ret = giffile->SWidth;
*height_ret = giffile->SHeight;
*numComponents_ret = 4;
+#if (GIFLIB_MAJOR >= 5&& !(GIFLIB_MAJOR == 5 && GIFLIB_MINOR == 0))
+ DGifCloseFile(giffile, &Error);
+#else
DGifCloseFile(giffile);
+#endif
return buffer;
}

1 change: 1 addition & 0 deletions dev-games/openscenegraph/openscenegraph-3.2.1-r2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -91,6 +91,7 @@ DOCS=(AUTHORS.txt ChangeLog NEWS.txt)
PATCHES=(
"${FILESDIR}"/${PN}-3.2.1-cmake.patch
"${FILESDIR}"/${PN}-3.2.1-gdal-2.0.patch
"${FILESDIR}"/${PN}-3.2.1-giflib5.patch
)

src_configure() {
Expand Down

0 comments on commit c775cf1

Please sign in to comment.