Skip to content

Commit

Permalink
app-admin/awscli: Bump to 1.27.72
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Feb 16, 2023
1 parent 8da9d91 commit c7956a4
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/awscli/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST aws-cli-1.27.64.gh.tar.gz 2363382 BLAKE2B fd0879e793aa5ee449ee535425976d11e
DIST aws-cli-1.27.69.gh.tar.gz 2366011 BLAKE2B e2ac484bb6ead107d0deca6bad5b9ca4a014f129d1253528869c303d72d58f1e9d5329b6c3180ec53190e43711d999b7026764c0cf65786903dade2a5c135f88 SHA512 85d6d820918ab42ce39e3a90751726a8dbf691083f5d71834b61b8456f6c91e3cac7ead86448187a3853a26f9e75e2e1d7f2acd3a8de59a69ebc028a4692b9ac
DIST aws-cli-1.27.70.gh.tar.gz 2366135 BLAKE2B f8feedc28ff2b94326ea81ef1c38779c709ca88033c6f36a31dd28659f9f7cfe2fe520dcf39c46534e5d91e48877e0901e212fc3316effe3e0dc5b0c4855c47d SHA512 faae6ea80047736d99d16cc652b43c4b34fe70822c3aa5a59c8c505a79bbc8b573c4b875f8551c934f20119f0ac2a4ea86a0d91614d5a3871b32a2ea0cc9139c
DIST aws-cli-1.27.71.gh.tar.gz 2366507 BLAKE2B e01193919c0f78a8e1ea0e12a2fb7c454604553d1c3d86d42aa120ba7f31f9d3e1f8cfe602da5f575a589181643ff895e2dd99b4d5dd73c2eeade1ce956c6e33 SHA512 428ca6198d13764968f50a29f38904419401f4f807bcd09a9c8e5bae62410acb1e4929acb8a3a8ff255ab21eecd78b6a68b46dc95f1f3c514a44ed13c57a6805
DIST aws-cli-1.27.72.gh.tar.gz 2367270 BLAKE2B e1df31c226a98a7f8241bac33bea402024ea7975de1d3c34e3ae2c971b4386ecd772617cdb803ac3569238ed623b7c8a11c3cdaf642d82aad89421b2f067f782 SHA512 54aaa158dd4832eeac20781a2f2c8e62123753a5b7d7273b7d1e33188d30a4c0a0991d9a7b49ebca7f682944e9fcd523412c5f6c47146c52400374d52d2524b8
80 changes: 80 additions & 0 deletions app-admin/awscli/awscli-1.27.72.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )

inherit bash-completion-r1 distutils-r1 multiprocessing

MY_P=aws-cli-${PV}
DESCRIPTION="Universal Command Line Environment for AWS"
HOMEPAGE="
https://github.com/aws/aws-cli/
https://pypi.org/project/awscli/
"
SRC_URI="
https://github.com/aws/aws-cli/archive/${PV}.tar.gz
-> ${MY_P}.gh.tar.gz
"
S=${WORKDIR}/${MY_P}

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"

# botocore is x.(y+2).z
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
RDEPEND="
>=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/rsa[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
!app-admin/awscli-bin
"
BDEPEND="
test? (
dev-python/pytest-forked[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

src_prepare() {
# do not rely on bundled deps in botocore (sic!)
find -name '*.py' -exec sed -i \
-e 's:from botocore[.]vendored import:import:' \
-e 's:from botocore[.]vendored[.]:from :' \
{} + || die
# strip overzealous upper bounds on requirements
sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
distutils-r1_src_prepare
}

python_test() {
local EPYTEST_DESELECT=(
# TODO
tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
)

# integration tests require AWS credentials and Internet access
epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
}

python_install_all() {
newbashcomp bin/aws_bash_completer aws

insinto /usr/share/zsh/site-functions
newins bin/aws_zsh_completer.sh _aws

distutils-r1_python_install_all

rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
}

0 comments on commit c7956a4

Please sign in to comment.