forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: David Seifert <[email protected]>
- Loading branch information
1 parent
9ab47c2
commit c7d3a3e
Showing
1 changed file
with
21 additions
and
20 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,39 +1,40 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=5 | ||
AUTOTOOLS_IN_SOURCE_BUILD=1 | ||
AUTOTOOLS_AUTORECONF=1 | ||
EAPI=7 | ||
|
||
inherit autotools-utils | ||
inherit autotools | ||
|
||
DESCRIPTION="VSQLite++ - A welldesigned and portable SQLite3 Wrapper for C++" | ||
DESCRIPTION="VSQLite++ - A well designed and portable SQLite3 Wrapper for C++" | ||
HOMEPAGE="http://evilissimo.fedorapeople.org/releases/vsqlite--/" | ||
SRC_URI="https://github.com/vinzenz/vsqlite--/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
IUSE="static-libs" | ||
# package name is vsqlite++, but github / homepage name is vsqlite-- | ||
S="${WORKDIR}/vsqlite---${PV}" | ||
|
||
LICENSE="BSD" | ||
|
||
SLOT="0" | ||
|
||
KEYWORDS="amd64 ppc x86" | ||
|
||
DEPEND=">=dev-libs/boost-1.33.1" | ||
|
||
RDEPEND="${DEPEND} | ||
dev-db/sqlite:3" | ||
|
||
DOCS=(AUTHORS COPYING ChangeLog INSTALL NEWS README.md TODO VERSION) | ||
|
||
# package name is vsqlite++, but github / homepage name is vsqlite-- | ||
S="${WORKDIR}/vsqlite---${PV}" | ||
RDEPEND="dev-db/sqlite:3" | ||
DEPEND=" | ||
${RDEPEND} | ||
dev-libs/boost" | ||
|
||
src_prepare() { | ||
default | ||
## remove O3 in AM_CXXFLAGS | ||
sed -i -e 's/-O3//' Makefile.am || die | ||
autotools-utils_src_prepare | ||
|
||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
econf $(use_enable static-libs static) | ||
econf --disable-static | ||
} | ||
|
||
src_install() { | ||
default | ||
dodoc VERSION | ||
|
||
find "${ED}" -name '*.la' -delete || die | ||
} |