Skip to content

Commit

Permalink
dev-python/argcomplete: version bump to 1.9.4
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Mar 29, 2018
1 parent a7c23e5 commit c7e3cca
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/argcomplete/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST argcomplete-1.4.1.tar.gz 37219 BLAKE2B eff9c8b8a2996d2d57ca99516071a1c831f9e64be4efd72bf930dfe7fb2404db2aa03546e761ae73b5d22f8ebe683728c433ab837eee5c073616e7d32fa32010 SHA512 3e9fa64fca93baf14fddd653947ff0269004e8783de0567931dafb9e4d0dfff2e2450ef6df331a4d648f5ce1d817a422f52d8d30b94315cd54fd82102467ded5
DIST argcomplete-1.9.2.tar.gz 46445 BLAKE2B a515fb1fdb94a78f02d01c90950bc21ac8000ccd54724e3037fb491097627a0f5de08b281dc13a7b531b4df6598f1aa1d7310932131a5a5a778dc5e5b39020d0 SHA512 174a4f7f1e24944472567c7cf2959b1bf1bf1d57f9c9d36469837f568d9e5db89d7055a2b93ff58e72fa5a78acb498833833a465da2b69bcf09fcfa2ecdad742
DIST argcomplete-1.9.4.tar.gz 47471 BLAKE2B ba64acc1fb2ae336166504db3dd991227c4e2a04abc6909ecf6723c1d2ce82ea65453ca2dde97316da9eaaa5b60026a6c8e4f3d658f1ed8122ca4fd00723fca1 SHA512 831958dffc75c65e2a63918d1e6f5e1fa47ec753b913c978e8d1d30d430ab8fedf66c99d8df23b2abc547b42c27335ccf47811224322994316ca2225c85ce346
33 changes: 33 additions & 0 deletions dev-python/argcomplete/argcomplete-1.9.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy pypy3 )

inherit bash-completion-r1 distutils-r1

DESCRIPTION="Bash tab completion for argparse"
HOMEPAGE="https://pypi.python.org/pypi/argcomplete"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~arm ~amd64-linux ~x86-linux ~x64-macos"
IUSE="test"

DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/pexpect[${PYTHON_USEDEP}]
app-shells/tcsh
)"

python_test() {
"${EPYTHON}" test/test.py || die
}

python_install_all() {
distutils-r1_python_install_all
newbashcomp "${S}"/${PN}/bash_completion.d/python-argcomplete.sh python-${PN}
}

0 comments on commit c7e3cca

Please sign in to comment.