Skip to content

Commit

Permalink
media-sound/spotify: bump to 1.0.96
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/675068
Package-Manager: Portage-2.3.54, Repoman-2.3.12
Signed-off-by: Nikos Chantziaras <[email protected]>
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
realnc authored and prometheanfire committed Jan 10, 2019
1 parent c453c51 commit c83b213
Show file tree
Hide file tree
Showing 2 changed files with 117 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/spotify/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST spotify-client_1.0.72.117.g6bd7cc73-35_i386.deb 95135550 BLAKE2B ad4587dd6b3c64a0398e0790203a7826e290a27542fa39ebbd6c7198d8ad1fd3fb06e8b030b64e1e61e0624ef20aafda08189266486cd073cb779ebff62ef502 SHA512 51d60f7592e5f31ea4b7e67736a85271cb48d4108459630da61c4ab67d2a470038240c1d6ff577280cb4498cf44f14d7bc7e0312f63d34265bcd1e70cd13142f
DIST spotify-client_1.0.94.262.g3d5c231c-9_amd64.deb 104191924 BLAKE2B 75d5067fee6333897e33dd43f3bea11f0811df30f9d3d35a537298675516e6e9c8af609460daaf2a79be91133b45a4b76c9539abee9cdbc04362caeefbbea27a SHA512 e6aa650a207fb636cd789055d4b17bc9c0fec1f6421877e4e80d3d5239f1a1bb881c5bfa4788a6cbe7748175e6c731af66a3395d2089d2d9a94dabfe5d07b09f
DIST spotify-client_1.0.96.181.gf6bc1b6b-12_amd64.deb 105145290 BLAKE2B 1ffb55ac3684d021b181e27d1183c5f0c1bd22ad8e6decbd64b0172a7925e824b6f74d40edbb1ae4401bf954860f47d9d1ffad6d879e85e02406869709d817cd SHA512 8ecff0657849058863deb8fce9304d4c9aa5a511f8043a0ba52d138a29979d3217da7568ab2058271f3e448206406fc0e1651ba7d438f677b1a2036ecb5937e2
116 changes: 116 additions & 0 deletions media-sound/spotify/spotify-1.0.96.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,116 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit gnome2-utils pax-utils unpacker xdg-utils

DESCRIPTION="Spotify is a social music platform"
HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
SRC_BASE="http://repository.spotify.com/pool/non-free/s/${PN}-client/"
BUILD_ID_AMD64="181.gf6bc1b6b-12"
#BUILD_ID_X86=""
#SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb )
# x86? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_X86}_i386.deb )"
SRC_URI="${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb"
LICENSE="Spotify"
SLOT="0"
KEYWORDS="~amd64"
IUSE="libnotify systray pax_kernel pulseaudio"
RESTRICT="mirror strip"

DEPEND=">=dev-util/patchelf-0.9_p20180129"
# zenity needed for filepicker
RDEPEND="
dev-libs/openssl:0
dev-libs/nss
gnome-base/gconf
gnome-extra/zenity
media-libs/alsa-lib
media-libs/harfbuzz
media-libs/fontconfig
media-libs/mesa
net-misc/curl[ssl]
net-print/cups[ssl]
x11-libs/gtk+:2
x11-libs/libXScrnSaver
x11-libs/libXtst
dev-python/pygobject:3
dev-python/dbus-python
libnotify? ( x11-libs/libnotify )
pulseaudio? ( media-sound/pulseaudio )
systray? ( gnome-extra/gnome-integration-spotify )"
#sys-libs/glibc

S=${WORKDIR}/

QA_PREBUILT="opt/spotify/spotify-client/spotify"

src_prepare() {
# Fix desktop entry to launch spotify-dbus.py for systray integration
if use systray ; then
sed -i \
-e 's/spotify \%U/spotify-dbus.py \%U/g' \
usr/share/spotify/spotify.desktop || die "sed failed"
fi
default

# Spotify links against libcurl-gnutls.so.4, which does not exist in Gentoo.
patchelf --replace-needed libcurl-gnutls.so.4 libcurl.so.4 usr/bin/spotify \
|| die "failed to patch libcurl library dependency"
}

src_install() {
gunzip usr/share/doc/spotify-client/changelog.gz || die
dodoc usr/share/doc/spotify-client/changelog

SPOTIFY_PKG_HOME=usr/share/spotify
insinto /usr/share/pixmaps
doins ${SPOTIFY_PKG_HOME}/icons/*.png

# install in /opt/spotify
SPOTIFY_HOME=/opt/spotify/spotify-client
insinto ${SPOTIFY_HOME}
doins -r ${SPOTIFY_PKG_HOME}/*
fperms +x ${SPOTIFY_HOME}/spotify

dodir /usr/bin
cat <<-EOF >"${D}"/usr/bin/spotify || die
#! /bin/sh
exec ${SPOTIFY_HOME}/spotify "\$@"
EOF
fperms +x /usr/bin/spotify

local size
for size in 16 22 24 32 48 64 128 256 512; do
newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
"spotify-client.png"
done
domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
if use pax_kernel; then
#create the headers, reset them to default, then paxmark -m them
pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
eqawarn "You have set USE=pax_kernel meaning that you intend to run"
eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
eqawarn "you suspect that ${PN} is being broken by this modification,"
eqawarn "please open a bug."
fi
}

pkg_postinst() {
gnome2_icon_cache_update
xdg_mimeinfo_database_update
xdg_desktop_database_update

ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
ewarn "To remove the cache:"
ewarn "rm -rf ~/.cache/spotify"
}

pkg_postrm() {
gnome2_icon_cache_update
xdg_mimeinfo_database_update
xdg_desktop_database_update
}

0 comments on commit c83b213

Please sign in to comment.