Skip to content

Commit

Permalink
dev-lua/luaevent: update EAPI 7 -> 8
Browse files Browse the repository at this point in the history
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Feb 9, 2022
1 parent cf1802b commit c86e23f
Showing 1 changed file with 61 additions and 0 deletions.
61 changes: 61 additions & 0 deletions dev-lua/luaevent/luaevent-0.4.6-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

LUA_COMPAT=( lua5-{1..4} luajit )

inherit lua toolchain-funcs

DESCRIPTION="Binding of libevent for Lua"
HOMEPAGE="http://luaforge.net/projects/luaevent"
SRC_URI="https://github.com/harningt/luaevent/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
REQUIRED_USE="${LUA_REQUIRED_USE}"

RDEPEND="
${LUA_DEPS}
dev-libs/libevent:0=
"
DEPEND="${RDEPEND}"

src_prepare() {
default

local mysedargs=(
-e "'s/CFLAGS =/CFLAGS +=/'"
-e "'s/LDFLAGS =/LDFLAGS +=/'"
-e "'s:-I\$(LUA_INC_DIR):\$(LUA_INC_DIR):'"
-i Makefile
)

eval sed ${mysedargs[@]} || die
}

lua_src_compile() {
tc-export CC

emake LUA_INC_DIR="$(lua_get_CFLAGS)"
}

src_compile() {
lua_foreach_impl lua_src_compile
}

lua_src_install() {
local myemakeargs=(
DESTDIR="${ED}"
INSTALL_DIR_BIN="$(lua_get_cmod_dir)"
INSTALL_DIR_LUA="$(lua_get_lmod_dir)"
LUA_INC_DIR="$(lua_get_CFLAGS)"
)

emake ${myemakeargs[@]} install
}

src_install() {
lua_foreach_impl lua_src_install
}

0 comments on commit c86e23f

Please sign in to comment.